BTT VERY resource hungry due to MIDI

Describe the bug
Hi, since adding the MIDI functionality in the latest version, BTT goes on to require a lot of CPU power (50%) when Traktor DJ Software runs. It seems to have to do with Traktor's virtual midi output which serves to set clock speed with other software (to sync beats) only and nothing to do with the actual midi controller, as even when a midi is not plugged in the problem persists. Additionaly, it's obvious in the midi event viewer in BTT that it's being drowned with MIDI signal from Traktor's virtual midi.

Would be amazing to have this fixed as using midi controllers to control app switching and other osx functions during live music performance is a dream.

Thanks!
Peter

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MIDI (Ableton K2 Controller)

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 2016
  • macOS version: 10.14.4
  • BetterTouchTool version: latest - dont know where to find the version id

Hey,

for now if you remove all midi triggers from BTT it will disable all midi related functionality (may require a restart).

I'll check if I can reproduce the issue somehow! But probably I need to add a config to only connect specific MIDI devices to BTT. I'll look into that.

BTT 3.069 alpha adds MIDI Settings where you can choose which MIDI devices BTT will connect to! (Currently uploading, will be available as alpha update in about 10 minutes)