BTT update for M1 freezes computer, cpu at 100%

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
BTT notified me of an automatic update optimized for Big Sur and M1 processors. Immediately after updating my computer became unresponsive. I restarted twice and couldnt get to activity monitor before the computer became slow and unusable. After waiting minutes, I was able to open activity monitor and I force quit BTT. It kept relaunching, and I force quite three times as I tried to delete the BTT app. most times it would relaunch before I could drag it to the trash and it would freeze again. finally got it deleted and will have to go without BTT untill this is resolved. really disappointed in the quality control on this release. MBP15, 2017, 2.9ghz intel i7, 16gb, Catalina 10.15.7.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MBP15 2017
  • macOS version: 10.15.7
  • BetterTouchTool version: No idea, deleted it. it was pushed out to me 11/12/2020 first version for bigsur/m1 (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Apple currently encounters issues with their Gatekeeper service probably due to the Big Sur update released earlier. It’s currently causing all sort of issues for all kind of apps.

This will probably be resolved soon.

Would probably work as a temporary fix until Apple has fixed their servers

Also see