BTT Trial Version outdated/expired early

Receiving error the BTT app version is outdated/expired. I am using a trial version, I only downloaded it 2 days ago so still plenty of time left. It is the most recent version of BTT 3.936
Consequently app is disabled/unusuable. Was running fine up until an hour or two ago.
MacBook Pro 2021 running latest OSX Ventura 13.0.1

Have restarted computer, as well as tried reinstalling BTT, no luck

same issue in 3.936 and had left 23 days for trail, checked the update but it shows me there is the newest version.
Change to update to the Alpha version 3.949 and this issue still exist

Same issue for me. I checked the update but it shows me: "Update Error ! An error occurred in retrieving update information. Please try again later.". I had 26 days left.

Same issue here

Buying a new license fixed the issue for me

I have just uploaded a fix for the early trial expiration issue. Checking for updates should show it now.


Thanks, update to 3.951(2116) now the problem had been solved.

To prevent this from happening again in the future, should we turn off automatic update checking ?

Does this happen often? I was about to buy a license, this is not exactly inspiring confidence...

@confused_user Will never happen to versions with a valid license. It's just trial versions that can expire early, so don't worry.

@mjrod Disabling update checks does not help - the opposite is true, having automatic updates on usually prevents this from happening (not today though). However this only affects trial versions, with a valid license BTT never expires.

1 Like