BTT Trial expired

Hi guys, I've an old license of a previous version (I guess 2.4) of BTT and I'd like to add some functions for key long pressing, but I guess I can't do it with mine (or can I? Cannot find anything about it).

So I downloaded a demo version of the last version of the new BTT but, when I launch it, it shows as disabled. For sure I tried some demo versions of the app various times in the last years, to see if there was something useful in the new features; but so far I already had what I needed.

Schermata 2022-07-21 alle 07.59.16

As result I cannot try the new demo. The "Enable BTT for..." doesn't show anything.

Any solution about it? I guess I just need one or two days.

Thanks.

Buy a license. Simple enough.

Without knowing if it will work or not?

You can't keep getting trials, it says at the top of your screenshot, your trial has expired.. Its $10 for a 2 year license, that's not much more than a Happy Meal at McDonalds.. There is no reason it shouldn't work..

Yes, sorry - I can not provide integrated ways for resetting the trial.

You can probably use tools like App Cleaner to remove any BTT files though and then reinstall.

Thank you for your answer Andreas, I was able to make it work again.

I'm trying to configure my ESC key so a long press will put the Mac to sleep, but it's not working.

I created a new action, pressing the ESC key and setting "Trigger on key Down" with "Minimum time key needs to be pressed" set to 1,31 seconds. But nothing happens when I keep the key down.

I also tried with another key (F1) following these instructions:

The short press works, long press not.

I'm (still) using Mojave, on an old 2012 Mac Mini. Could this be the problem?

Thanks.