BTT Trackpad Gesture to Keyboard Shortcut Does not Work in Mission Control

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug

I have an app called "Mission Control Plus" that lets me close the window under trackpad pointer when I am in the mission control. All you have to do is move your pointer to the window you wanted to be closed and press CMD+W to close the underlying window.

Having also BTT, I set up a trackpad gesture that sends CMD+W keyboard combination to close tabs/windows under the cursor (this becomes super useful in web browsing by the way.) However, what I noticed is that, in mission control, BTT trackpad to keyboard transformation does not stack with the Mission Control Plus app's features. That is, I can still close windows under my cursor if I use the keyboard combination (i.e. I press manually CMD+W) with the help of that Mission Control Plus app. However, if I keep the Mission Control Plus app on and have BTT send (via a trackpad gesture) the "CMD+W" keyboard press, nothing happens in mission control.

I am aware that there is a "Close windows below cursor (works in mission control) option" in one of the options in BTT, however, that option does not really do the same thing as CMD+W, I want to be able to close tabs very quickly with a trackpad gesture "Close windows below cursor (works in mission control) option" doesn’t do that.

I hope my problem is clear and there is a fix for this problem.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
"Trackpad Gesture to send a Keyboard Combination" feature of BTT

Device information:

  • Type of Mac: 15" Mac (Late Fall 2016)
  • macOS version: Catalina (10.15.5)
  • BetterTouchTool version: 3.373

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
You may perhaps need to contact the "Mission Control Plus" app developer:

like this?????
the btt button is invalid In the mission control interface

no one can help me?

I forgot that I even reported this bug. Thanks for the video, that’s not exactly my problem. My problem was specific to the keyboard shortcuts, but I learned to live with it for now.

Since the my Mac keyboard started falling apart, I haven’t been spending a lot of time with my Apple hardware, though I still love BTT. I barely missed the 4 year keyboard replace campaign of Apple (why 4 years? Because that’s exactly when it will start falling apart, that’s why). So until I buy a new mac, I won’t be enjoying BTT as much as I used to because I started using my work computer more often then my personal computer.

Although, I must say, going back to windows is like having a one night stand with your ex-wife, the morning after you realize why you divorced the dumb bitch. (Pardon my French)