BTT (touchbar) exits randomly

I use BTT only for my touchbar. It basically replaces the apple standard touchbar with some simple command buttons.

Problem 1: When i press those buttons, BTT will quit randomly. Doesnt matter what button i press. Sometimes it exits after pressing just one button. sometimes it'll exit after i press 10 times on those buttons.

Attached a video to show what happens.

Problem 2: Sometimes, instead of BTT quitting, I'll just see a horizontal dotted line across my touchbar (and only the "x" circle on the far left remains. rest of the BTT configured buttons gone and replaced by the horizontal line). Dont have a video of this yet, but will try to get one.

Help please.


Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
As above

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook pro 13" Mid 2018.
  • macOS version: 10.15.5
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I restart BTT, but it will happen again as shown in the video.

Does anyone know where I can support for this? I've got a fully licensed product but can't use it properly.

Unfortunately I haven't seen such an issue before. However there have been various Touch Bar fixes and improvements during the last two weeks, possibly try upgrading to 3.167