BTT Touch Bar does not show up anymore

Describe the bug
The touch bar ignores BTT and display classic OSX touch bar.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2018)
  • macOS version: 10.14.6
  • BetterTouchTool version: 3.202

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
It seems the update of BTT software has to do with it since I didn't update my os version.
BetterTouchTool app has all usual permissions to do its job.

Thanks for helping !

probably it’s just hidden. Use the predefined action „show/hide Bettertouchtool Touch Bar“ to toggle it (e.g. assigned to a keyboard shortcut)

BTT worked great on my MacBook Pro 10.14.6 for the first week, then suddenly disappeared. Its processes appeared normally in the process monitor, but no BTT touchbar no matter what I tried. I did a clean re-install of BTT, and it appeared again--then disappeared again. After about 3-4 rounds of this, I then selected the "Show Menubar Icon" option, and no problems for a couple of days so far, knock wood. Other apps (namely, 1Password) also suggest showing their menu bar icon as a way to ensure the program stays resident. Is that a factor with BTT?

The "just hidden" theory has been confirmed. Thanks for helping. Still I did not have this behavior before.

Since it has been said to check the "Show Menubar Icon" could mitigate the issue, I did it too. :+1:

Have a nice day.

Where is there an action called "show/hide Bettertouchtool Touch Bar"? I've looked through all the actions, and I can't find it.

You can find it there:

1 Like

Sorry if this is super basic but I also can't see the custom Touch Bar in the last few days.

And I've tried to follow the above instructions but the Keyboard shortcut is not working.

Do you have to save a new shortcut? I don't see a place to do that... Below is the code for the shortcut I made.

"BTTTriggerType" : 0,
"BTTTriggerClass" : "BTTTriggerTypeKeyboardShortcut",
"BTTPredefinedActionType" : 188,
"BTTPredefinedActionName" : "Toggle BetterTouchTool Touch Bar",
"BTTAdditionalConfiguration" : "1048584",
"BTTEnabled2" : 1,
"BTTKeyboardShortcutKeyboardType" : 0,
"BTTUUID" : "D339F713-9F83-442D-A284-81A87386A949",
"BTTTriggerOnDown" : 1,
"BTTNotesInsteadOfDescription" : 0,
"BTTLayoutIndependentChar" : "`",
"BTTEnabled" : 1,
"BTTModifierMode" : 0,
"BTTShortcutKeyCode" : 50,
"BTTShortcutModifierKeys" : 1048576,
"BTTOrder" : 0,
"BTTDisplayOrder" : 0,
"BTTAutoAdaptToKeyboardLayout" : 0

Toggle action did not work :frowning:
I add a new keyboard shortcut for the Show touch bar and now it works.