BTT Stops working after Sleep/Hibernation

Description of bug:

When waiting from sleep or "hibernation" BetterTouchTool will frequently stop working properly.
Tackpad gestures are no longer recognized, window snapping no longer works, and many other features stop work.

I also have a "menu bar" icon setup with a few shortcuts; one being to launch BTT preferences, which none of them will work. Clicking "BTT Preferences" launches finder..

Launching BTT again to open BTT Preferences loads the BTT Preference Window, but no content will load within it..

The only way to recover is to Force Quit BTT, and relaunch it. Then everything goes back to working.
Sometimes BTT does not appear in "Force Quit" which requires launching "Activity Manager" to close BTT from there..

This started in the Sonoma release; been happing for a while, only just had the time after much frustration to post something here about it.

Its rather annoying, since BTT has become the primary tool for shortcuts, like switching Desktops, activating Mission Control, etc.. all this stops working, hindering productivity so I can stop what I'm doing to restart BTT.

Device information:

  • Type of Mac: MacBook Pro (Apple Silicon)
  • macOS version: Sonoma 14.2
  • BetterTouchTool version: 4.334 (43340)

PS: "Restart BTT after wake from sleep" is enabled, but does not resolve the issue.
Though that is not a "fix" .. its just sticking a band-aid on the problem.

Weird, this has been an issue in the past and I have investigated it intensively (there are many threads for this topic from before October). However after the fixes released in 4.308 (End of October), it seems to have been working on all systems I know about.

Two things:

  • disable "Restart after sleep", it should not be necessary and probably won't help
  • if you have the experimental Dropbox or iCloud sync enabled, try to disable it. It has been causing weird issues since Sonoma.

However your issue sounds much weirder than those from before October. I can't think of any reason why clicking "BTT Preferences" would launch Finder :-/
It would probably be helpful if you could go to Help => Export Diagnostic Debug Information and send the result to me (, maybe I can see something from the logs.

The "Restart after Sleep" was enabled shortly after the issue started happening. So yeah, doesn't seem to help w/ it enabled or disabled.

I disabled the iCloud Sync. Since I don't use it anymore; I've just been using rsync (via Syncthing running on a local Debian server) to sync BTT between my other Macs. Would be nice if we could get an option to set a local mount location to create a save/sync point. Instead of having to use a cloud service.

Log file was sent; I just grabbed the one with the extension .log .. There was an incident with BTT earlier today, between 10AM - 10:30AM (not sure of the exact timestamp, but might look around there in the log.

If you need the whole folder BTT created on my desktop; let me know and I'll send it all.

I don't know Why it was launching finder; that was something new it started to do last week. Before that, when BTT would just stop working with many of the functions. The BTT shortcut in my custom menu bar would just do nothing when clicked.

In the meantime, I setup a Automator (application) triggered via Shortcuts to restart BTT (Basically just killing it's running processes, and relaunching it) .. another band-aid.

Edit: I just send the whole Debug folder anyways.

I peeked through the logs;
there are a bunch of references to "TB|Force show Touch Bar|" (or Touch Bar in general) which my MBPro doesn't have.

Not sure of the reverence, but just found it odd it was trying to act upon a device not available.

Just adding that I have the same problem.

I'm using Dropbox for syncing though otherwise exactly as described.

most likely the experimental dropbox/icloud sync is causing the issue. I have plans to completely replace it with something better soon. For now, disable it.


unfortunately I am experiencing the same issue.

I turned off the sync service, but it did not help. After sleep, the whole app stops working. :frowning:

Debug info WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Device information:

  • Type of Mac: MacBook Pro M2 MAX
  • macOS version: macOS 14.1.1 (23B81)
  • BetterTouchTool version: 4.346

I'm also experiencing this and also using dropbox for sync

I'd like to add that something has happened recently, either with dropbox or with a recent BTT update.
I can't recall exactly when it was my latest update but I'm currently on 4.356

I say this because this issue was happening from time to time for me but now it has become the norm, any time my mac goes to sleep, even for a minute I'm forced to either:

  • Deactivate BTT for all apps then Activate for all apps (it works randomly)
  • Restart BTT (this works all the time but it's annoying and it's not a fix)

What can I do to provide more information about this issue?

Sorry for the multiple replies but in the latest 2 weeks or so this has become unbearable for me, it's happening 100% of the times.

Should I open a new thread as this seems a new issue somehow? :thinking:

have you tried to deactivate the dropbox sync?

Thanks Andreas!
Just tried and disabling the sync seems to fix it, i will keep on testing in the next days.
Why tough? I haven't changed anything in my system, didn't update dropbox, maybe I've updated BTT but I can't recall on which version the issue became persistent.

Is this a fix? Meaning we should give up dropbox sync for now or you might somehow be aware of what could cause this and a possible fix?

yes, keep it disabled. The dropbox sync was always very experimental, and some update of either macOS or Dropbox seems to have broken it for some users. I'll remove it & replace it with something better, but this will still take a bit.

1 Like

The Sync options do not seem to be the cause.

I'm continuing to have the same issue; BTT just randomly stops working, especially after waking from sleep/hibernation. It's happening more and more frequently.

  • Touchpad Gestures stop working (I use BTT in place of the built-in MacOS gestures to move between Spaces (Desktop) and activate Mission Control.
  • The BTT Custom Menu I Have in the Mac menu bar disappears.

There might be multiple causes, the sync option is definitely the most common one right now (unfortunately).

In your case it might be something different. I can have a look at your logs if you go to Help => Export Diagnostic Debug Information and send the result to (best right after reproducing the issue)