BTT stopped working after latest update to BTT

I updated to version 4.462 a few days ago & I'm having trouble with Mac Sonoma 14.3.1. (I'm not updating to Sonoma 14.4 because of reported issues with printers, etc, which I cannot risk.)

I use Jump Desktop (remote desktop app). I have actions in BTT that paste plain text which used to work. Now, it usually fails to do anything. Sometimes BTT sends a single "delete" key. Sometimes, BTT sends a whole page of "code" with parenthesis, curly braces, weird text, etc.

At the same time, although the BTT icon loads in the menu bar, often the BTT icon isn't appearing in the touch bar. Even on initial boot up of the Mac or restarting BTT.

I've tried restarting the Mac, reloading BTT, checking for new versions, etc.

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

unfortunately macOS 14.4 changed quite a few things and I had to adapt some things in BTT. For most users it doesn’t change anything, but one important change is that older versions automatically added a delay after each keyboard shortcut sent by BTT. This can affect BTT in some apps.

You can enable this behavior again by checking the „add small delay“ option in BTT‘s keyboard settings. Then it should behave like before.

Even on older macOS versions it can make sense to define the delays explicitly via the "async delay" action though. Previous versions of BTT added 100ms between each keyboard shortcut, but that was kind of arbitrary. Some apps required more, but most required much less / none at all.

However I don't think there has been any Touch Bar related change.

Thanks for the quick reply. Unfortunately, that checkbox has made no difference. Further testing reveals that the insert text action (via pasting) actually just pastes whatever is already in the Mac clipboard, rather than pasting the text that's meant to be pasted. Note that this has only occurred since updating BTT to 4.462 & was not a problem on earlier versions. I have not updated the MacOS or apps. That checkbox also would not explain why the BTT app fails to properly load before any actions are even started.

The Touch Bar stuff is probably unrelated, for that I'd try to restart your Mac. I can't think of any change that is relevant to this.

Does pasting via BTT work when not going through Jump Desktop? It's possible the macOS 14.4 related changes don't work well through that. The timings for the paste action had to change (slightly) as well. Maybe that's problematic for Jump Desktop.

For now I'd recommend downgrading if you rely on that app: Index of /releases
Maybe I can add an option to add longer delays for specific apps with one of the next releases.

Thank you. I've installed 4.460 & the problem remains. I wonder if my config files have somehow become corrupted. How can I check that? Where are they stored? (Perhaps I can retrieve something from Time Machine.)

ah the last widely rolled out stable version was +- 4.442, you can check in ~/Library/Application Support/BetterTouchTool what was your last version (go there via Finder => Go=> Go to Folder, make sure to include the ~). 4.460 already contains the 14.4 fixes.

However it would be good if you could check whether pasting works outside of Jump Desktop before downgrading.

Best also create an export of your presets as downgrading can be a bit risky without backups.

Thank you. My last version seemed to have been 4.427. I have reinstalled this & everything works again.

I did test 4.462 & 4.460 with the pasting of plain text action in TextEdit --> this worked. I didn't test in other apps.

1 Like

I have made some changes aiming to improve this in 4.465, would be great of you could test it at some point

Hi Andreas, thank you for working on this. I've tried 4.465 & something has changed, but not quite right. When pasting a plain text as an action, the Windows menu (within the remote environment) seems to activate before the text is pasted, perhaps as an initial keypress. It's all a bit fast for me to see what's happening. I've reverted to 4.427 for now.