BTT Stopped Opening, Now "Version Incompatible"

Last week, my BTT stopped opening altogether. I tried installing the latest version of BTT, restarting my system, uninstalling and reinstalling BTT, and resetting privacy settings. Nothing worked. Finally, I downloaded an older version that matched my settings files. Now I see the following error message (even after re-installing the newest version):

"BetterTouchTool version incompatible

The Version of BTT you are currently using isn't compatible with the version of your data file!
Older copies of the data files are stored in ~/Library/Application Support/BetterTouchTool."

Help would be greatly appreciated!

**Affected input device: MacBook Touch Bar

Device information:

  • Type of Mac: MacBook Pro 2019
  • macOS version: Ventura 13.4
  • BetterTouchTool version: 4.100

I'd try to download the latest version from Index of /releases

The message usually appears if the data files had already been migrated to a newer BTT version, then can't be used on the old version anymore.

Best create a backup of the ~/Library/Application Support/BetterTouchTool folder first

Hi Andreas,

Thank you for your reply. I've made a backup of the ~/Library/Application Support/BetterTouchTool and downloaded the latest release from the index of /releases. I'm still seeing the same error message that the BTT version is incompatible. How can I proceed from here? Would it be easier if I shared the ~/Library/Application Support/BetterTouchTool folder with you?

Thanks so much.


Following up as this error message still persists. How can I proceed, given the information above?

Thank you.

You can send the ~/Library/Application Support/BetterTouchTool folder to, then I'll have a look!

Hi Andreas,

I've emailed twice with the BTT folder (on July 17th and August 18th) and haven't yet heard back - I suspect the emails may have gone to your junk folder. If you could take a look to locate the emails, I would appreciate it. The subject is " Bug Report: BTT Stopped Opening, Now "Version Incompatible". I'd like to get this resolved since my BTT standard license is still active.

Thank you.

I have the same issue. Stopped working out of nowhere and cant get it to start again.

This message can have many reasons, essentially it just means the current data file is not readable by the current version of BTT. The database could be corrupted or a bad upgrade => downgrade => upgrade cycle has happened.

First create a backup of ~/Library/Application Support/BetterTouchTool, then try to delete the most recently changed file ending with -wal. That sometimes already fixes the issue.

If not try to use Help => Restore Settings From Backup within BTT.

1 Like

Thanks, Andreas! I had to delete a few of the -wal files before it started working again.