BTT stopped opening after update

Just had an issue with BTT not opening after updating to the latest version.
My mac is not very up-to-date, so I'm pretty sure this is the reason.

I thought the app might be corrupted, but reinstalling did not resolve this.
For now I ended up installing an older version of BBT and it's working again, till i'm on the latest OS again.

Just wanted to post this in case someone had the same issue recently.

Device information:

  • Imac
  • BTT version: 4.212
  • macOS version: Bug Sur 11.4

i got the same issue in Big Sur 11.7.7

whats the last version that works for you?

Same here :frowning: Very bleak.

Saw @Andreas_Hegenberg recommend on another blog, changing the folder name under application support, but that just deleted entire setup and also now when importing a saved preset, the app just crashes.

Chip Apple M1
Memory 16 GB
macOS Ventura 13.5.2

1 Like

@dozer93 @Julian_Steinmann I currently don't have a 11.x installation, could you check whether there are any crash logs in the macOS console app?

BetterTouchTool-2023-09-12-234500.crash (6.2 KB)
I think this one

If it's any help, yesterday I had a bug where better touchtone keep asking for location premmisions.
not it doesn't work.
tried to reinstall.

I'm having this problem too. MBP 16" 2019, 2.3 GHz 8-Core Intel Core i9, 16 GB 2667 MHz DDR4, Ventura 13.5.2 (22G91). It's just stuck in a deathloop – I see it pop up in the menu bar and then disappear after a second. Worse, it seems to be interrupting my typing, as I'm seeing keystrokes vanish.

I have a bunch of .ips files from console crash reports but can't seem to attach.

ips files would be great, can you send them to

If BTT keeps relaunching try this terminal command:
killall BTTRelaunch && killall BetterTouchTool

I am currently running on MacOS Sonoma, and I can't even open BetterTouchTool anymore.
Everytime I try to start the App, it shuts down before any window is opened.

I can very shortly see the icon appear in the touchbar, and then it shuts down again.

Skærmbillede 2023-09-14 kl. 08.31.58

I just emailed them, thanks.

@nshady Could you try removing BTT from the list in System Preferences => Privacy & Security => Accessibility, then add it again? Your crash logs look like macOS doesn't remember the permission was granted.

//Edit for anybody else trying this: quit BTT before doing this.

1 Like

Well, that turned out to be a bit of a trap, because when I deactivated it (BTT still running – mistake), it recognised the deactivation of privileges and prompted going to System Settings... but the MBP stopped acknowledging all keyboard input and clicks. Had to hard restart.

On restart BTT asked for privileges again but this time I could activate it – and then BTT crashed again. Now it's back up... seemingly stable ish?? But I'll send through two more crash reports.

Oh I didn't know that macOS bug was still there (freezing the system when removing running apps from that list) ;-( I have reported that a loong time ago to Apple.

But it sounds like this was some permission issue then. Not sure if the other reports here are the same issue. Looking at the crash logs I think this thread has multiple different issues come together.

Will let you know if it starts misbehaving again. Hopefully it was just something funky happening during the update process and now permissions have been regranted it will be stable.

Alas, it's back to misbehaving. Repeatedly opening, stalling, and crashing. I'll email any new reports.

Could you check whether this build solves the issue for you? (also available via alpha update)

Thanks. I'll give it a go, but fair warning, as BTT crashes before loading it's impossible to get via in-app update mechanism (alpha or otherwise).

It's loaded up okay without crashing, will monitor for a bit.

@d0zer44; Didn't really check what's the latest that works. I just went a few down and the first one I checked worked:


For me the same issue persists with your new build.
Sent you a crash log in an email.

I think the macOS 11 issue should be solved with 4.247. The issue was caused by an Xcode bug (App built with Xcode 15 beta 8 cra… | Apple Developer Forums)