BTT/Slack crashing

After many months I've just found the need to use Slack again. Previously BTT and slack played together without issue, but now, both apps become unresponsive when simultaneously open. To resolve, I need to force close both apps, and they both work fine as long as the other isn't running. When force slack I get multiple "name is a required value." error messages with the BTT icon.

I don't have any BTT shortcuts or actions that use slack, but I've noticed it BTT created a slack specific section for actions, that also has a disable BTT box (which was on by default but I've tried toggling off). I've tried deleting this entire section without success.

I've tried restarting, updating my mac, reinstalling slack, updating my mac, making sure BTT is up to date but no luck. Any idea what I should do?

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2019 16 inch macbook pro
  • macOS version: 14 beta
  • BetterTouchTool version: BetterTouchTool 4.181

Additional information (e.g. crash logs, related issues, etc.):