BTT sent me back into trial, and removed all my settings

Describe the bug
After recently updating bettertouchtool, I kept recieving a popup (although I can't remember the exact phrasing) and every time I hit Okay, it would reappear. I believe it was something about saving.

Now I've been able to open BTT, all of my settings are gone. Including all touchbar buttons, and snap areas.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touchbar, Keyboard, Snap Areas


Device information:

  • Type of Mac: MacBook Pro 15" 2017
  • macOS version: 10.13.14
  • BetterTouchTool version: 2.503

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Following: Restoring Backup made no difference, still showed up as not configured when relaunched.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Mhm, maybe there was some file permission error and BTT couldn't access its settings.
There are various backups you can try to restore, see

Do you know whether your license is still valid for this version? (BTT licenses are usually for 2 years of free updates, but you should have been notified if it wasn't eligible for the version anymore).
If not, you may want to downgrade to the last eligible one ( )

It's definitely still valid, the license was purchased September 2017.
And I've tried the restore with no luck

Could you send me the contents of that backup folder? Then I can send you the files you need to copy in to restore it. This should definitely work.

Best to send it to

I was able to get them from an old Time Machine backup and had success.
I'm wondering if the files were corrupted somehow?