BTT seems to think there is more than one action defined for a particular trigger

When I trigger my "Lock Screen" action, I get a popup menu with three lines in it, all of which say, "Lock Screen". If I click on the first entry it works, but none of the others do. I have double-checked, and I definitely only have one trigger defined with this keystroke. If I change the keystroke to something else, the popup menu goes away, but changing it back to the keystroke I want to use causes it to return.


I'll also try uploading an export of my settings:
Default.bttpreset (59.4 KB)

Device information:

  • Type of Mac: 10.14.5
  • macOS version: iMac (Retina 5K, 27-inch, 2017)
  • BetterTouchTool version: 3.04

Your action seems to work fine here, do you maybe have other presets active in addition to the one you attached?

No, this is my only preset.

Looking at the exported .bttpreset file in a text editor, it looks as though there is some junk leftover from when I was testing. Search for "Lock Screen" and you'll see multiple references to running "/usr/bin/say hello". These are actions I deleted, but they still appear in the export file.

Ah that's interesting, I'll look into that.

Ah there seems to be an issue in the new UI that let's you drag items that already have children into other items that already have children. This will confuse BTT.

That's why your screenshot shows these two triangles:

I'll prevent this in the future. For now just delete the sub-items under these triangles, then it should work I think.

Ah! I didn't notice the extra children there. I tried deleting them, but that didn't help. I deleted the entire command, recreated it, and that worked.