BTT seems to be set to LISTEN on port 54776


when running lsof I can see

benwoodhouse@~ % lsof -nP +c 15 | grep LISTEN

BetterTouchTool 9560 benwoodhouse 13u IPv4 0x6b3b81281df0be35 0t0 TCP *:54776 (LISTEN)
BetterTouchTool 9560 benwoodhouse 14u IPv6 0x6b3b8128133867d5 0t0 TCP *:54776 (LISTEN)

Even though I haven't enabled the web server, is this necessary? Is this a security vulnerability?

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):


this is for BTT Remote. If you don't use the BTT Remote iOS app you can disable it in the settings, but it won't allow a connection without explicit confirmation :slight_smile:

Hey Andreas, Apologies I didn't see this in the config. Thanks for the quick response, consider this one closed!