BTT - Restore Old Window Size problems

Very often, if I resize windows... I can't get them back to the original shape. I've been testing some different scenarios, but I can't seem to be able to reproduce it on demand. Once I open BetterTouchTool window, it usually starts working (sometimes I have to enable/disable the affected shortcut), at least for a while.

I know the following comment "sucks", but... this didn't happen to me before and I use this feature all the time. Could this be due to Mojave?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MackBook Pro 13" 2016
Keyboard shortcut:

  • CTRL+Option+Z = Restore Old Window Size
  • CTRL+Option+Right/Left Arrows = Maximize Window Right/Left


Device information:

  • Type of Mac: MackBook Pro 13" 2016
  • macOS version: 10.14.2 (18C54) Mojave
  • BetterTouchTool version: 2.660 (but problems started already before)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Just let me know what you want, and I will do my best to produce it.

Happy Holidays!

I'm also seeing an issue with restore old window size. I use the "move window to next monitor" function, as well as "maximize window" function. I had expected that pressing "restore old window size" would return the window to being the same size and monitor as previous to pressing "maximize window" but the window ends up being on a different monitor.

Bump. Same issue on Mojave.

Still here. Catalina july 2020

I'm trying this on Big Sur and it doesn't appear to do anything.

I'm assuming the expected behavior is for the window to revert to its previous size.

I might to do some more digging... but I think that I can reproduce it. If I for example open iTerm2 and maximize it, or maximize it to just one half, or whatever... and then try to go back to it's original shape and place, it works. But if I start open/close tabs on it and then try to get back to it's original shape, then nothing happens. I saw some tendencies of the above at work today.
By the way... I have also tested this on a new MacBook Pro 13" M1 running and the older Mac I started this thread with, both with new installs of BigSur... still the same problem.

Otherwise... Everything works and I'm a happy camper.
Keep up the good work! :wink:

Hmmm I'd tried to bind Restore Old Window Size to OPTION+CMD+Z. I then created a random new browser window, changed its size, press the keyboard shortcut and nothing happens. Maybe I misunderstanding how to use this?