BTT restart loop

I haven't used BTT in a while. Today I started the app and updated it to latest version. Then I saw the GDPR notice and that's the "restart loop" I'm seeing. I see the GDPR notice, click "Continue" button and then "Start using BTT & open preferences" button. Then I get back to GDPR notice.

It seems like it could be file permissions?

Device information:

  • Type of Mac: MacBook Pro (Retina, 13-inch, Mid 2014)
  • macOS version: Mojave 10.14.6
  • BetterTouchTool version: 3.209 (1386) and also tried on 3.213 (1390)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
The app seem to be working (also without valid license!), if I just ignore the GDPR window (as you can see in the last screenshot. I've got some gestures from awhile ago and they still work, but it's just really inconvenient, and I do have a valid license, it's just not activated yet on this machine.

This can happen if there is a file permission error where BTT is unable to write to it's own data file.
This can e.g happen if you rename your macOS user account or if you restore data from a time machine backup.

To fix this, either follow Apple's file permission fix guide (

Or just delete the BTT settings file (~/Library/Preferences/com.hegenberg.BetterTouchTool.plist). However other files might be affected as well.

1 Like

Thanks Andreas!

Indeed, the file was symlinked to the wrong location in my Dropbox account.

I use mackup ( to backup my preferences to Dropbox and that seems to have messed it up.

I've fixed it now by linking to the correct location.

1 Like