BTT Remote doesn’t see MacBook Pro on wifi network

Describe the bug
I just installed BTT Remote on my iPhone. When I launch the app it shows a list of computers. My computer is not on the list.

There are two laptops in the house, both MacBook Pros and both running BetterTouchTool. The BTT Remote app on my phone only sees one of them, and it is not mine.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

BTT Remote on iPhone XS

Device information:

  • Type of Mac: 2013 retina MacBook Pro 15.4″
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.646 (956)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I suspect this is not really a BTT bug, but rather that I need to configure something on my laptop to let it show up. However, I do not know what that might be.

Both computers have the same settings under System Preferences for Network, Sharing, and Security & Privacy. My understanding is that BTT Remote uses Bonjour to find computers, and that it should “just work”—but it isn’t working for me.

I posted about this a few days ago here in the Discussion & Questions subforum, but didn’t get any responses so I’m trying again in Bug Reports.

Do you maybe have a firewall installed?

I have tried both with the firewall (in System Preferences/Security & Privacy) on and with it off. My observations are the same for all firewall settings on both computers: the other computer shows up for BTT Remote regardless of its firewall settings, and my computer does not show up regardless of its firewall settings.

weird.Something must be blocking bonjour on that computer, but it's hard to tell what :frowning:
Usually it's a firewall, sometimes a bad router configuration / firmware...

Yeah I can’t figure it out either.

Now I’m trying the "connect with IP and Port” option which says “The IP and Port are shown in the BetterTouchTool preferences on your Mac”, but I don’t see that info in BTT prefs. Where should I look for it?

in the BTT Remote tab below the table :slight_smile:

1 Like

Ah yes, I had that tab hidden. Trying to connect manually timed out.

However, when I unchecked the “Enable BTT Remote Support” box, then checked it again, it immediately popped up a dialogue asking if I wanted to allow BetterTouchTool to accept incoming network connections. That had never popped up before, and now my computer does appear in the list.

When I tried connecting though, it still timed out. So I went into System Preferences and turned off the firewall. At that point, finally, BTT Remote was able to connect to my computer.

But when I turn the firewall back on, even with BetterTouchTool allowed to accept incoming connections, the app cannot connect.

For reasons that should be obvious, I would like to keep my Mac’s firewall turned on. So, is there a way I can configure it to let BTT Remote work while my firewall is still on?

Edit: I restarted my Mac with the firewall on and now it works. Thanks for the assist!

2 Likes