BTT Remote crashing BTT

Describe the bug
I open up the iOS BTT remote app (on iPhone X, iOS 14.3) and tap on my listed MacBook (auto-discovered via Bonjour). On doing so, the BTT application on my MacBook crashes.
The BTT remote app times out trying to connect (due to the BTT app on my MacBook crashing).

Device information:

  • Type of Mac: MacBook Pro (Retina, 15-inch, Early 2013)
  • macOS version: Catalina
  • BetterTouchTool version: 3.510 (1648) (latest alpha version at time of writing)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
BetterTouchTool_2020-12-29-144458_macbook.crash (94.9 KB)
This appears that it might be some sort of SSL problem; I don't see any BTT related items in my keychain. Should I have something there?

Weird. Did you recently encounter any weird behavior related to your keychain? (e.g. macOS being unable to access some items?)

The item in the keychain should be named "BetterTouchToolRemote_New" but the crash suggests BTT is unable to access the keychain for some reason.

I haven't encountered any other weird behavior with the keychain, but I don't see any item named "BetterTouchToolRemote_New" in keychain access.
I did start doing some things with the keychain and ended up with a second empty 'login' keychain, but that was after you mentioned "BetterTouchToolRemote_New " as I wanted to see if the keychain item was in any backups I had.
Should BTT be able to regenerate keychain items if it can't find them or is that something I would have to do? I've tried doing a total BTT uninstall and reinstall and still no keychain entry showing up by that name. I don't think I got any keychain access prompts from BTT at any point if that makes a difference.

Imprint | Privacy Policy