BTT quits on sleep

After updating to the latest version, including Alpha. BTT quits on sleep. I have to start it every time macOS wakes up.

Version 3.581 (1724)

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I've recently switched to an M1 Macbook Pro from an Intel machine; BTT was pretty solid on the Intel machine but crashes regularly on the M1 - it seems I'm seeing this 'crash on sleep' behaviour? (though my mac doesn't sleep, it's always powered on; display off only). Basically, I log in from the display lock and BTT's gooooone.

Are there any kind of logs I can gather?

(also on Version 3.581 (1724); macOS 11.6 (20G165)

I am also seeing this annoying silent crash on sleep behaviour. Late 2015 Macbook Pro, macOS 11.6 (20G165) — BTT version 3.581

I had a look in Console > Log reports > Bettertouchtool.log but no errors are seen, neither in the system.log / Crash reports / diagnostic reports...

I'm seeing similar - btt very regularly not present after a wake. This is on iMac Pro (Monterey beta) and M1 MBP 13" (Big Sur). It's been happening for at least a couple of months - I didn't log it as I only saw it on the Monterey beta, and expected that you'd get around to it in the usual way. But now I've got the M1 and I've been seeing it on Big Sur there as well occasionally. For me it's much worse on the Intel/Monterey than on the M1/Big Sur.

I've got very quick at cmd-space-be-enter, but it's not ideal :slight_smile:
BTT v 3.581

+1 on this. I'm using an iMac with OS 11.6 and BTT 3.581. This either started happening because I recently upgraded to 11.6 (from Mojave) or to this latest BTT at around the same time. I should mention that I have tried the "Restart BTT after wake from sleep" option both checked and unchecked, and there is no difference.

This will be fixed in the next release (which still takes about a week because it contains many new features related to the new shortcuts app on monterey)

For now you could downgrade to this version which shouldn't have this problem: https://folivora.ai/releases/btt3.571-1715.zip (but export your setup first)

3 Likes

@Andreas_Hegenberg does "Restart BTT after wake" help?

Imprint | Privacy Policy