BTT often doesn't work after opening laptop

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
After I wake my Mac from sleep (by opening the lid), BTT does not work. I have custom gestures set up on certain applications and also all apps. The BTT icon is still in the top bar, so it looks like it's running, but it doesn't actually do the intended function.
In order to get it working again, I have to restart BTT.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Air M1, 2020
  • macOS version: 12.4
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.936 (2101)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):