BTT not working properly

Where can I get in touch with someone from BTT? I need to ask some questions on why after paying for the license it magically stopped working and no matter what I try nothing seems to fix it. Thank you

paying for BTT does not influence its behavior, so most likely a coincidence. If you have concrete examples of what doesn’t work, post them here on the forum, then I’ll probably able to help

Well actually as I paid for it it asked to update the version I was using, and from that moment on bugs started to appear. I'm using BTT to be able to use my razor tartarus on my mac for photoshop shortcuts. I'm having a hard time explaining by writing what's going on so I recorded a video if that's not an issue.

Thanks a lot for the help, i'm losing my mind trying to figure out why it doesn't work anymore :sweat_smile:

It's a bit hard to understand because macOS doesn't have key events for 12, 13, 14 etc., instead the razor seems to send normal "letter keys"?. What does it output if you type on this device while BTT is not running?

Maybe go to Help => Export Diagnostic Debug Information and send the result to, maybe I can see something in the logs.

Do you remember what version of BTT you used successfully with this device?

Well when not using BTT the tartarus 12,13,14 correspond to a,s,d. I just sent you the files by mail. Also i'm sorry but i have to idea which version it was, I just know I downloaded BTT around the 20th of February, maybe that helps ?

Thanks a lot for your help btw!

What I find weird is that it was working perfectly before

The files you sent don't seem to contain the configured triggers shown in your video anymore, did you delete them?

However from the logs I see that there must have been some recursive triggering. This means a triggered shortcut was sending an action that caused it to trigger itself again endlessly. For example shortcut E, to trigger action "E" would lead to an endless loop breaking the functionality in BTT. Similar if you have a shortcut e.g. "e", that triggers "a" and another shortcut "a" that triggers "e".

Make sure to check for such possible recursions.
Also try to enable these two options:

yeah i deleted them as it was not working. How do I check for possible recursions? I tried configuring the shortcuts while enabling the two options shown in the picture but the issue stays the same. Although the key 14 on the tartarus is configured to the key s on my laptop keyboard, whenever I press it it mimics the shortcut for the key 13 (which is b in this case). If I change the shortcut of 13 to let's say e, then 14 will become e aswell... I don't understand why it copies it

if possible send the files again when a non-working trigger is configured, that way I can check the config :slight_smile:

Alright just sent you the new files, thanks!

Considering the issue started when I updated BTT, do you think there's a way for me to go back to the old version I was using ? I'm on a tight timing rn and need BTT to work assap for professional reasons

Yes, you can, all versions are available here: Index of /releases

I think this setup is not possible with BTT (as it's not a key remapping app and you are essentially trying to remap the keys of your keyboard).

The problem I see from the screenshot you sent:
You have assigned key 19 C => A and A => E and E => cmd+D.
This means when you press 19, it will execute A, that will trigger E and that will trigger cmd+D.

I don't know how this would have worked with previous versions. It should never have worked unfortunately ;-(

hey Andreas, I just downloaded the old version i was using ( [] ) and everything went back to normal. All the shortkeys work and everything is fine... not sure why it works with the old version and not the new one...

I just sent you the files via email in case you wanna check it out...

ahh your last sent files showed me how it was working :slight_smile:
I believe it's not working in the new version due to a bug that accidentally made it work in some older versions that was fixed recently. However I think your usecase is valid, so I made that bug standard behavior now.

I think your setup should work again with 4.461 (uploading now), would be great if you could test with that once it's available!

Just tried with the new version and it still doesn't seem to be working... the same issue as before arises

That is weird, did you do the setup again? (it might not have your triggers in the new version due to the downgrading)

I also just uploaded 4.462 which should improve it a bit more.

The important thing from your old version was that every trigger had the "Only works on keyboard used for recording" option enabled.

I have also added a more generic option that you could activate:

Here is an export of your preset from v4.403, you can import that into the new version:
razer.bttpreset (70.7 KB)

No it still doesn't work. This time the triggers act differently, they're wrong but in a different way than before

Actually Mb I activated the 'dont process keybord shortscuts' box and now it works perfectly just like the old version! Thanks a lot