BTT not opening.

Describe the bug

BTT is not opening. It actually opens and closes immediately. I didn't make any changes to the system settings or to BTT settings, nor did I restart the system. Yesterday I used it as normal, but today it's not working anymore. I bought a license this year, in February 2022.

What I tried to do:

  1. Restart the computer.
  2. Reinstall the app.
  3. The steps on this link: - Great Tools for your Mac!
  4. The steps on this link: - Great Tools for your Mac!
  5. Force quit "BTTRelaunch" in Activity Monitor.

None of these worked. :confused:

It seems like it keeps trying opening itself too. I see a flicker in the touchbar and the app I'm using gets greyed out, as if BTT opened and then closed itself again.

I went to the and there were several reports of BTT when the computer was supposed to be asleep. They all say this:

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Missing bytes from file at path /Users/______/Library/Application Support/BetterTouchTool/.BTTClipboardManager_SUPPORT/_EXTERNAL_DATA/230E9271-8DE5-4345-B3FB-5C6F7B5E52BC, expected 3526990274, got 18446744073709551615'
abort() called
terminating with uncaught exception of type NSException

Can somebody help?? Cannot live without this app.

Thank you!


Device information:

  • Type of Mac: Macbook Pro M1
  • macOS version: Monterey 12.0.1
  • BetterTouchTool version: BetterTouchTool 3.784 (May, 22, 2022)

Additional information:

sounds like your BTT database got damaged.

Easiest would be to delete/rename this folder: ~/Library/Application Support/BetterTouchTool (go there via Finder => Go => Go to Folder, make sure to include the ~)
However this would delete your BTT setup.

That worked!

I'll have to set things up again but small price to pay.

Thank you!!