BTT not detecting modifier keys sent from Logitech mouse

I read something about connecting logitech mouse m720 to BTT as mapped shortcuts since they no longer get interpreted as button 3,4,5,6.

For example, I set this mouse button to this keyboard shortcut.

But now when i go to BTT and try to click that button to record it as a shortcut, it only reads it as "Y" without any modifier keys.

So my guess is that BTT doesn't detect those modifiers when they are sent through Logi Options. I tested it out by just typing the shortcut, and it recorded it, but it doesnt actually do anything when pressing that mouse button.

Anyone experience this?

could you try this terminal command while BTT is quit?

defaults write com.hegenberg.BetterTouchTool BTTUseHighLevelModifierKeys YES

So I reinstalled Logi Options+, and now BTT is detecting all the modifiers and keys while recording, but doesn't do anything when assigned to an action.

After executing the terminal command, it no longer detects the modifier keys while recording a shortcut and is back to just recording letters. I tried this a couple times a while back too, and I could never get it to detect any modifiers when sending shortcuts from the buttons. Gonna restart mac and try it all again.

Edit: Yea, still not detecting any modifiers while recording shortcut after restarting and executing that command again with BTT quit.

Andreas, hey :slight_smile:
Sorry for bad eng)

I have same problem with Logitech g604
In Logitech Options i use macros to map additional mouse buttons to keyboard shortcuts
Button 4 5 6 7 8 to NumPad 1..8 keyboard buttons, but BTT not recognize modifiers when i record shortcut
Example: Add trigger and record shortcut => Press Shift and Ctrl => Click Mouse Button (Pad1) => In record only Pad1... When i use button all modifiers stopped registering and not record

  • BUT If i use Karabiner Elements (now i don't) all modifiers completely recognized, all works!
  • In World of Warcraft modifiers similar not working, BUT if use defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES, all modifiers completely recognized!

defaults write com.hegenberg.BetterTouchTool BTTUseHighLevelModifierKeys YES had no effect, only buttons without modifiers

May be exist additional params?

Additional info:

  • I use karabiner on big sur, on ventura and sonoma i not install this
  • Macroses from logi options record in onboard memory in this mouse (on windows pc 2 years ago), logi options app never installed on macos

Yeah, i've read about workarounds with like steermouse and keyboardmaestro too, but I was hoping to find some way to get it working in BTT, because its easy to use and understand. If I need it that desperately, i guess I could try that, thank you!

i'll have a look at the latest logitech option app soon.
For now, maybe you don't even need modifier keys. If you choose this option, it will not affect your standard keyboard:

Hmmm, I just tried this with mouse button assigned to cmd+shift+2, recorded it with a button click, selected that option and saved, and it still appears to be executing the screenshot action when pressing "2" on my keyboard.

Can you fix the whole app while you're at it? :joy: Such an annoying app to use.

Yes, I'm working on adding full Logitech support to BTT in the coming weeks /months. Logitech Options and the like won't be necessary anymore then.

1 Like

it doesn't depend on the logi options or other logitech software
All functions, macroses, dpi, etc records in onboard memory in mouse
Need to figure out why when you click the any additional (with macroses) button all modifiers are reset

Maybe need upload debug log or any informations, where u might see what is going on when buttons pressed?

Will be great to see full Logitech support.

Any update on addition of full Logitech support to BTT?

I would also be interested in full Logitech support. The app is horrible, and BTT offers so many more features (for example, support to check what website as a condition)

any updates for logitech support? @Andreas_Hegenberg

I made an account just to add to this too. I've been following closely since the changelog mentioned it was coming back in Jan of '23, but struggling to find any info on how it's progressing along.

Even if it's been put to the back of the queue, would love to know if the Logitech support is arriving anytime soon. I absolutely hate their software and this would finally let me ditch it!