BTT no path to upgrade license

Describe the bug
I formerly used BTT, and decided to try it again. I got the latest BTT with homebrew, and applied the license that I had. The license is too old for this version of BTT, and I'm given a dialog to downgrade or buy a new license (or continue with the trial). So I purchased a new lifetime license.

Every method I try to apply my new license leads me to the same dialog box, offering me the opportunity to buy the license again. Once an old license is applied, there is no option to use a different (possibly newer) license file. This includes clicking on the "Register BetterTouchTool" link in the email from Paddle. They all just bring up the dialog to buy a new license.

For someone who has just paid to upgrade, this is a little insulting.

I am not allowed to "try the latest (Alpha) version", because my installed, old license doesn't cover that.


Device information:

  • Type of Mac: MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports)
  • macOS version: 10.15.7 (19H114)
  • BetterTouchTool version: 3.508 (1646)

Could be a file permission error because by default clicking a registration link or double-clicking a license file will replace the previous one.

You could try to repair permissions on your disk, but a simpler solution would be to just delete all *.bttlicense files from this folder:
~/Library/Application Support/BetterTouchTool
(Go there via Finder => Go => Go to Folder, make sure to include the ~)

Afterwards it should work fine.

Thank you for your help!

All of the permissions look normal to me, the only exception being the license file itself had an additional attribute. (This file was retrieved from my 1Password software licenses database.)

ulmer@SLU-MacBook-Pro ~ % ls -@al ~/Library/Application\ Support/BetterTouchTool/*bttlicense
-rw-r--r--@ 1 ulmer  staff  761 Dec 15 20:14 /Users/ulmer/Library/Application Support/BetterTouchTool/bettertouchtool.bttlicense	 15 

I just removed the existing license file, restarted BTT, and was able to license through the menubar icon as I would have expected. I would not have been able to do this either time if there were a permissions problem in the parent directory hierarchy.

Note that regardless of why this particular problem happened, there is still no way to ask BTT to apply a new license file from the license dialog when an old license already exists. My problem is solved, but I would expect the author would want to fix that.