BTT keeps closing on me for no apparent reason

BTT keeps closing on me for no apparent reason. This started happenning since I got a new MacBook. New Mac is OS Big Sur version 11.4 on a MacBook Air (M1, 2020). I'm running BTT version 2.428, and have been a very happy user for a few years now :slight_smile: Would appreciate any leads on how to resolve this. Thanks!!

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

You really shouldn't run these old versions on M1 Macbooks. They are not made for that processor architecture.

Could you send me a link to something more 'with the times'? That's the version I found online in the BTT website 2 months ago.

The latest versions are always available via https://folivora.ai/downloads

Imprint | Privacy Policy