BTT is using a lot of CPU and making my MacBook Pro hot

BTT always asking me accessibility permission, tho it has it already. I tried to remove the app from the list and then add it again. same problem on both mac book laptops. always want permission, and I need to quit the app and then open it again to have this gone.

The affected parts are the fans and the CPU because it is always running very high because of this pop-up permission window. Sometimes I don't see it, so it stays in the background burning my laptops.

Device information:

  • Type of Mac: Macbook Pro and Air
  • macOS version: Lastest 12.5.1 (21G83) Monterery
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.844 lastest of today.

Would you please tell me what I can do? the laptops are being burned with the high CPU usage. and I don't like the idea of always closing and opening the btt app.

Thanks in advance for your help!

do you have the experimental dropbox or icloud sync enabled? If so, disable that

1 Like

Hello dear Andreas,
I have both Dropbox and OneDrive installed on the devices and on auto-sync. I don't know what exactly you mean by experimental? Both versions are stable, no beta or something.
Can you please clarify this please.

Thank you in advance!

I mean the sync in BTT:

If that is not active, it sounds like some file permission error. You could try to completely remove BTT from the accesibility permissions and then add it again.

1 Like

Oh, yes, I had that on, and I also had some permission problems, so I turned it off. The accessibility permission is not for the sync. I tried to remove the app from the list and then re-add it again. Still the same issue.
Now I have just tried the terminal resit code. I hope this might work! Do you have any other suggestion to do while waiting to see if the terminal code works or not?

This comes again even after the terminal code reset. Any suggestions dear? @Andreas_Hegenberg
Thank you so much in advance :pray: