BTT intercepts left option key

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

BTT intercepts left option key. If I quit BTT, the problem goes away.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

MacBook Pro keyboard

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 16-inch 2019
  • macOS version: 13.4.1 (c)
  • BetterTouchTool version: BTT version is 4.173

Additional information (e.g. crash logs, related issues, etc.):

In general modifier keys can not be intercepted at the level on which BTT works.
You can assign functions to them in BTT but BTT can not block them if they are pressed on their own.

Maybe you have defined a key sequence in BTT that does something when option is pressed? Or maybe a keyboard shortcut, which now doesn't work outside of BTT anymore?

This is most likely not a bug, but some configuration issue. Can you describe in more detail in which situations the left option key doesn't work anymore?

Hi Andreas,

Strangely, only the left option key is affected. The right option key works normally.

I don't see anything in my BTT settings that would affect the option key.

I'm using the left option key with the left and right cursor keys to move from word to word during text editing. I'm also using the left option key as part of the cmd-opt-shift-del key sequence to immediately and permanently delete an item from a removable drive.

Quitting BTT makes the left option key functional again.