BTT Hyper-Key - not ready for prime time

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.
On Big Sur I tried switching my hyper-key (caps lock = shift, ctrl, option, cmd) functionality to BTT. I ran into several problems and have shelfed the attempt.
Problems I encountered:

  • non-responsive - would hit a combination a nothing would happen, would it again and action occur
  • Key would "stick" - after using hyper-key the system would "hold it down" and subsequent typing act as if the hyper-key still pressed.
  • To get keyboard back to normal I would need to restart BTT

For now, back to Karabiner-Elements for Hyper-Key

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Imprint | Privacy Policy