BTT gesture for Spotlight activation / command-space shortcut doesn't work. Normal?

Hello everyone.

Since recently upgrading to Catalina (I know, I'm late) I'm missing the dashboard for unit/currency conversions. I use Launchbar as my launcher, but I know spotlight is pretty good at conversions so I tried setting my previous dashboard gesture to launch spotlight but I can't get it to work consistently. For reference the gesture is 4 finger swipe down. The gesture even doesn't work for triggering the command-space shortcut (I can physically use command-space no problems).

I can occasionally get it to register when I switch between the key down/key up and down dropdown menu and save, but even then it works once, and sometimes twice and stops. I've also tried various other simpler gestures to no avail.

Is this s BTT bug or some deeper level MacOS thing?
Thanks for any info!

I can't think of any reason why bringing up spotlight wouldn't work (it works fine here)

Is it enabled in System Preferences => Keyboard => Shortcuts?

1 Like

Yes, but only the top option has been checked. As that’s the shortcut I want.

So you have the shortcut working fine?
Is there meant to be an option for spotlight, like “show desktop” in the BTT actions menu? Because if so I don’t have one. Searching the BTT actions brings up no results for the term “spotlight”.

I’m running the latest Catalina and latest BTT as of today.

There is no explicit action, I'm just triggering the shortcut on my machine like this:

Well, for some reason it's working now. I started/restarted BTT a few times, and for the first 3 or 4 times it was working with the first gesture, then did not work when trying the gesture again. Changed to "key up/down" from "key down" on the dropdown menu and it appears to be working.

I also moved it to the top of the triggers list (was below four other triggers) so this may have something to do with it? (just moved it back to the bottom and still working properly). Not 100% sure what was going on but I'll update this thread again if the problem comes back.

Thanks for your help

1 Like
Imprint | Privacy Policy