BTT freezing mouse in Heroes of the Storm

When inside Heroes of the Storm (menu and game, makes no difference), mouse1 temporarily freezes mouse movement when pressed down. This has been a persistent problem ever since I purchased BTT nearly a year ago.

I have only tried with two different mice and the trackpad, but the issue remains there.

  • Type of Mac: MacBook Pro 15" (2016)
  • macOS version: High Sierra
  • BetterTouchTool version: All of them. 2.536 latest included.

It's probably a bug in how the game handles the default macOS APIs. You can however just disable BTT for that game.

BetterTouchTool doesn't recognize the game like it normally does for other apps. I added it manually to the list as by your screenshot and disabled Heroes of the Storm, but that still didn't work. Might be because the game is launched through the Blizzard launcher. World of Warcraft had the exact same problem last time I tried it (about 9 months ago).

Just to update, World of Warcraft still has the same exact problem. Doesn't matter if I play in fullscreen or window mode. The problem persists. I added it to the exception, but it doesn't do anything.

I should note that World of Warcraft vanilla on private servers does not suffer this issue. It is only the retail version.

Edit: Actually, Magnet causes the same issue to happen.

If the game can not be recognized using the standard means, you can try to create a "conditional activation group" that matches parts of the path to the game.

image

I copypasted the path from applications and used the settings showed above, i.e.
appExecutablePath > contains > /Applications/World of Warcraft

It only disables BTT when I launch the game. After switching to Safari and back to the game, BTT is back on :frowning:

Hey there, just want to chime in. I have been seeing the exact same issue. Each time you click while moving the mouse while in a game (any game it seems like), the mouse freezes then there is a minor ~200-500ms lag before the mouse catches up to where it should be.

I have resorted to disabling BTT completely while playing games. It makes shooters impossible.

I would like to followup that the workaround does fix things.

I added a Conditional Activation Group where "Executable Path" contains "/steamapps/" that has 'Disable BetterTouchTool' checked.

Pew pews are back online.

Imprint | Privacy Policy