BTT doesn't work with Safari 13.0.2

Just upgraded Catalina today (Mac App Store version), the trackpad doesn't work at all with the latest Safari (v13.0.2), tried to use the same gestures in Chrome (v77.0.3865.90) and it works fine. Look forward to fix it ASAP.

**Affected input device: MacBook Trackpad

Device information:

  • Type of Mac:MacBookPro15,2
  • macOS version: Catalina
  • BetterTouchTool version: v3.204

The trackpad doesn't differentiate between applications, if it works in one of them it will work in all of them.

However maybe something in your setup is not supported on Catalina Safari anymore? What gestures do you have configured in BTT?

Thank you for your response. In fact, these two browsers use almost the same gestures, and worked fine before the Safari v13.0.2 upgrade. I looked at the BTT Trackpad configured carefully but didn't fine anything wrong.


Mhh possibly Apple gave the Japanese(?) Safari a new name or identifier on Catalina? Could you try adding Safari again and copying over your gestures? (Just select them all and press cmd+c to copy and cmd+v to paste in the duplicated Safari)

Actually, It's Chinese:grinning: I tried the solution that you said and it seems didn't work. I can deal with Chrome until Apple fix it. Thank you anyway Andreas!

Ah sorry, is this the correct one? (So I can try to reproduce with the correct settings)

Could you maybe send me the debug logs (Main Menu => Help => Export Debug Information) to andreas@folivora.ai ?

YES, that's correct.
I tried to copy some of the gesture (e.g. Make the next/previous tab the active tab) from Safari to the global gesture, and it worked! The rest of the gestures, which were not copied to global, still no effect. However, I just emailed you the debug log, hopefully can help, thank you again:)

Very weird, your settings seem to work fine here.
Have you already tried to restart your machine? Maybe Safari is still confused from the upgrade? :slight_smile:

:sweat_smile: For sure, restart Safari and MacBook at least 3 times, It is weird, feels just like Safari's problem, cause didn't change any BTT Settings before updating to v13.0.2.

I get the same problem, all applications works fine but Safari(ver: 13.0.2).
It seems like that BTT can not detect safari. When I open safari, Touch Bar does not show the icons set for safari

I happened to encounter the similar incident. But i have solved that when I noticed Admin's comments. Maybe you once changed your mac's language. So BTT keeps the oringinal language of the app's description. you can delete the configuration of the apps with original names and add new configuration. For example, in Chinese pinyin, Safari is 'Safari 浏览器', and it's different from that in English, which is just 'Safari'.

1 Like

Ah that's interesting! Thanks for figuring this out!
I think if you use the "select from filesystem" option to add an app to BTT, it will use just the location / universal identifier, so you could also try that.

1 Like

It work! Turns out it was Apple added Chinese translation name for the application in new OS. Thank you very much that solves the riddle.

Hi Love btt
just have same issue when the new system update. how do I change Safari 浏览器 to Safari?Just try several way to do it. Still can not change it. Could u give me some idea?
Chen

How do u fix it? same issue. please let me know thx

how could I do this, same issue. or when u could fix the bug? please let me know. thx

delete it from the list and add it again :wink:

1 Like

Just as Admin said, delete your old configurations of 'Safari 浏览器', and add new ones of 'Safari'. And it's better to 'select from file system' rather than 'from running applications', said by Admin.

Thx. Worked for me

Imprint | Privacy Policy