BTT does not save applescript source type change.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
After I set "Source Type: Apple Script from SCPT file" and choose a file, then I change the type to "Source Type: Apple Script" and paste script to the editor, then save it by clicking save button on top of the panel, then BTT changes source type to "from SCPT file".

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Just done with Keyboard Shortcut

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: iMac 27, 2017
  • macOS version: 12.5.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.860 (2011)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Please refer captured video.

This issue can be resolved by workaround until there is a fix: removing the item and add it again from the scratch.