BTT disables MacBook Pro 16 ESC Key

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
BTT blocks physical escape key. Device does not respond to a press as long as BTT is running. Pausing BTT also re-enables physical escape key.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook internal keyboard, physical esc key.


Device information:

  • Type of Mac: MacBook Pro 16"
  • macOS version: 10.15.1 (19B2106)
  • BetterTouchTool version: 3.209 (1386)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Workaround is disabling BTT or possibly remapping esc (since it sounds similar to the old Touch Bar esc-key problems) but I haven't tested that yet.

Seems to work fine on my MBP16". Do you maybe have an esc key configured in the BTT keyboard shortcut section?

That really was it.
I did not think about it since I (so far) only use trackpad gestures and must have tried quitting the setup of a keyboard shortcut with escape.
Sorry and thank you!

The physical ESC button works well for me, only not work well when I am using iTerm. Like editing some files in VIM is quite hard to exit the insert mode for example, I need to press and hold the ESC button. Anyone know if it is a bug on BTT or it is a bug in iTerm?

Thank you.

Seems to work fine in my iTerm. Are you sure it works correctly when BTT is quit?

Yes. I am sure. For example I tried in Terminal and works fine, but in iTerm does not :frowning:

And as soon as you quit BTT it works?

Maybe you also have an ESC key configured in the BTT keyboard shortcut section?

I found in Old Configuration UI exactly what you said. I just disabled and now it is working.

Thank you a lot :slight_smile:

1 Like

I might be having this problem, but not sure how to troubleshoot. I was using the trial version, and if I remember correctly, my escape key stopped working after the trial period ended. Is it conceivable that BTT could have some effect on escape keypresses even when not running? I was only using the touchbar section, so this seems unlikely, but this is a new laptop with very little customization set up, I'm not sure what else could be causing the issue. I'll note that I have two user accounts, which has been causing some weird, unexpected bugs.

Incidentally, BTT has been great, but I installed it to make the touchbar more useful, and I've since moved to using a separate keyboard, so I just have much less need for it.

BTT: 3.402
MacOS: 10.15.7

In case anyone runs into this issue, this fixed it for me as well.

I had just installed BTT on a MacBook Pro (16-inch, 2019) and was really puzzled why the ESC key wasn't working until I restarted the computer and realised it was working... because BTT wasn't running.

Thanks @Seiji !

1 Like