btt crashes after monterey upgrade(airpods connection error)

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
Crash appeared after the mac os monterey upgrade. Whenever I execute 'long press toggle' option for my "airpods connection" setting(this setting is attached below; I uploaded the original preset I used for this), touch bar flickered constantly(btt app turning on and off several times). Couldn't do anything with the app but to erase it.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

touch bar


Device information:

  • Type of Mac: m1 macbook pro 13inch
  • macOS version: monterey
  • BetterTouchTool version: (please post the exact version - not just "the latest one") : ver 3.601

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

This is the preset that I used for my 'airpods connection

'AppleHeadphone_v1_1_1.bttpresetzip (13.3 KB)

same here. that preset crashes BTT. disabling it helps.

Have you checked with BTT 3.609? It seems to work here

@Andreas_Hegenberg Yes, I did. There have been quite a few updates of BTT recently and all of them crash when the AppleHeadphone 1.1.1 is active. Do you want me to send you log file?

Yes, the full log would be great ( - it's located in the macOS console app under "Crash Reports"

@Andreas_Hegenberg just sent

Thanks! The crash should be fixed in BTT v3.610 (in 5 minutes available via "check for alpha version updates").
However I think the main problem might be that the python executable is not in the location that's used in the script:

On Monterey this should just be /usr/bin/python3

1 Like

Installed the aplha version and changed to /usr/bin/python3 however keep crashing. Downloaded latest Python version from the web - 3.10 and still keeps crashing...
Another thing I tried was to change the path to /usr/local/bin/python3 or /usr/local/bin/python3.10 and still no luck :frowning:

v. v3.611 WORKS :slight_smile: default path /usr/bin/python3

I think there was still one situation that could crash BTT if no valid icon_path was returned from the script. That should now be fixed in BTT 3.611. However I did only fix some problems in BTT - I can not tell whether the script in general behaves correctly. There have been lots of changes to Bluetooth on macOS Monterey, so it's very possible that the script does not work as it did before anymore.

It might be due to icon. When I installed BTTT 3.611 nothing was crashing and I was able to connect the airpods and see the battery level. However no icon was visible (just a simple google image search fixed it :-)). Let's see if the widget actually works and correctly shows the battery...

Thank you @Andreas_Hegenberg !
BTW Could you please check this:

Conditional groups do not work very well. Both in Lightroom and Safari. Touchbar only loads after manually switching tabs there and back (in Safari) or from Lightroom to desktop and back to Lightroom. Let me know if you would like me to send you some logs or if I can help you somehow...

You mean conditional activation groups that match a window title? Unfortuantely the system notifications on window title changes are not very reliable, this might not be something I can fix in BTT, but I'll have a look.

Yes, exactly. It indeed feels unreliable. With Safari I decided to turn on and off touchbar manually with 3 fingers force click. Not a big deals since I use BTT touchbar in Safary only for 3 websites. However for Lightroom it's quite annoying. With the preset I created everything works great except that to make it run I must 1) open Lightroom, 2) switch to Desktop and 3) switch back to Lightroom for the Touchbar to appear. Anyway, if you need any assistance let me know in the "The missing Lightroom Touch Bar" thread....

1 Like

Problem solved. Thank you so much. You guys saved my day :slight_smile:

however it seems like the widget does not work properly anymore. battery is at 99 % all the time for my Airpods Pro. How about yours @ekzmdark9 ? Does the battery indicator work with your Airpods?

Encountered the same issue. Thought it was okay for a while. I guess bluetooth modification on Monterey macOS is making this annoying issue.