BTT Application Not Responding, using 100% CPU, can't force quit application as it reopens immediately.

Describe the bug
The application froze and started using 100% CPU usage. I tried to force quit all BTT processes running from Activity Monitor. All processes except BetterTouchProcessPrioWatcher quit but BTT launched again immediately and once again froze before I could do anything. I tried quitting BetterTouchProcessPrioWatcher from the terminal using the sudo kill command but it relaunched immediately and BTT was still crashing. Also, occasionally the trackpad click stops working. This has only been an issue while BTT was not responding.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad

Screenshots

Device information:

  • Type of Mac: MacBook Pro 13" 2018
  • macOS version: macOS Catalina 19A526h (Lastest beta)
  • BetterTouchTool version: 3.172

the prio watcher doesn't restart BTT it only affects already started instances, however the BTT watchdog called BTTRelaunch may do so.
To completely kill BTT, try these commands:

killall BetterTouchTool && killall BTTRelaunch

However it would be great to know why it is not responding. If possible it would be awesome if you'd sample the process when this happens again using this terminal command:

sample BetterTouchTool -file ~/Desktop/BetterTouchToolSample.txt

And attach the BetterTouchToolSample.txt from your desktop afterwards.

I'm having a version of this, where the relaunch tool is frozen, can't be force-quit. It seems to be happening when I put the laptop to sleep and wake it up. I've had to do a hard restart to resolve this in the past, though killing the BTTReLaunch process worked this time. However, trying to launch tthe app then returns a peculiar Finder error "The Application Better Touch Tool is not open any more".

I'm having a similar issue. BTT ramps up to 100% and all input is laggy. Here's a sample of when that's happening.Sample of BetterTouchTool.txt.zip (39.0 KB)

Hello Andreas, sorry for the late reply but here is the sample document you requested. I couldn't upload the original txt file so I just changed the extension, I hope this will not be a problem.

BetterTouchToolSample.crash (105.9 KB)

Ah thanks. Seems to be a weird dead-lock when some specific database operations run at the same time. I'll look into it!

It would be great if you'd could post even more samples - the previous two give me a good idea about what's happening, but it's still very hard to identify the code that is leading to this.

Here's 2 more samples. Sample 1 was right on start up. Sample 2 was on going to "Configuration". Some more notes:

  1. High CPU usage happens on startup as well as any time going into config.
  2. I have GoldenChaos (latest experimental version).
  3. I have iCloud Sync with BTT on 2 laptops.

BTT Samples.zip (73.6 KB)

thank you! I haven’t looked at the new samples yet, but I know that other users where having issues when using the sync, maybe try turning that off until there is a better solution.