BTT and Logic Pro

Hey Andreas,

Hope all is well :slight_smile:

I've been a long time user of BetterTouchTool, mostly use it for the global keyboard/trackpad/magic mouse shortcut functions, it's a great app! Long story short, yesterday I updated my studio computer to a new MacBook Pro with an M1 Max chip and what I realized is having BetterTouchTool open at the same time as Logic somehow breaks Logic, recorded a quick video of what exactly is the issue:

In this recording I start by adding a kickdrum sample and copy/pasting it throughout a ~5 minutes long arrangement (I can recreate the same issue with any other audio file, the type of the sample doesn't matter). At 0:27, I just quickly try to select samples, no latency at all, everything's super smooth. Some copy/pasting, still everything's perfectly fine, zero delay. BetterTouchTool isn't running yet.

At 0:39 I open BetterTouchTool. From 0:45 as I try to repeat the same simple selection process you can already see the little latency between my mouseclick and the action happening - this subtle delay is enough to completely break the flow of any producing/engineering session already.

At 0:55 I overexaggerated the situation to clearly show on video just how problematic the delay it causes as a session would scale - the latency/delay caused by BTT I suspect is somehow in direct correlation with the amount of audio clips present in a session. When the latency/dropout happens the OS is spinning the beachball which weirdly didn't get recorded by Quicktime, no idea why (so between 1:05-1:07 for example, my mouse didn't "stop" there technically, it just lagged out spinning the beachball). The point is, my click at 1:10 only starts to produce an action at 1:13. Action at 1:19 registers at 1:22 completely bugged etc.

At 1:27 I quit BTT. Selection is smooth once again, zero delay between my clicks and actions.

Would greatly appreciate if you would be able to investigate the issue, but if it's too niche to mess with it I can totally understand.

I'm running macOS 12.1 currently, but the issue yesterday was already present on 12.0.1 which the laptop came with. Since the recording of the video I tried the latest alpha version too which is 3.668 (1799), problem is still present. In the video it's BTT version 3.626 (1778).

Thanks for the great app, hope you have a nice week :slight_smile:

Some apps are slow to respond to the API calls required for window snapping. Possibly disabling window snapping for Logic can fix your issue. Like done here for Finder:

Oh wow thank you so much - instantly solved the issue! :slight_smile:

1 Like