BTT and Final Draft 11 for Mac

When I click at the end of a line of text in my screenplay, the whole area to the end of that line is selected, rather than the cursor appearing at that point, the expected behaviour. It takes a second click to get rid of the highlighting and just see the cursor inserted at that point. This behaviour vanishes when BTT is disabled.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
iMac Pro

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: iMac Pro
  • macOS version: 10.14.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.186 (1365)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Probably a bug in Final Draft in relation to the Apple Accessibility API.
You can try to disable window snapping for the app, this might help:

Thank you for the reply. In fact, Window Snapping is already disabled, following a different problem I’ve had with other apps I use in the past.

Any other thoughts?

Best wishes

Peter

Probably reporting the issue to the authors of Final Draft will be the only real solution, as I can't modify their code.

You could try to disable BTT completely for Final Draft, but of course that's not a good solution.

I did report to FD - which is the industry standard screenwriting software - but when I discovered that the problem went away when BTT is disabled, they referred me, not surprisingly, to the BTT developer.

Do you have a reference ID for your bugreport? I can try to contact them again.

BTT won't be the only app that's causing this, because it is most likely due to the usage of standard macOS API.

Thank you. The header on the response was:

Final Draft Support Inquiry Ref: [ ref:_00D80PMy2._5002E1Q333c:ref ]

Their email address is:

customersupport@finaldraft.com

The person I was dealing with was Mikita.

Would I be able to reproduce the issue in this view? (just downloaded the trial)

Because it seems to behave correctly here as far as I can tell.

It doesn’t happen every time. I'm a writer and am using FD all day every day. Every so often, when I use the trackpad with BTT enabled to click at the end of a line or block of text, (to add some more text), the area between the end of that text and the end of the line gets highlighted. And if I just start typing anyway, it does behave as if it has been highlighted - ie the new text I'm typing replaces the highlighted area - which causes chaos on the page because of the formatting rules in FD.

I have several rules set up in BTT - save, delete, forward delete - which are enormously helpful for my script work, so I have just been putting up with this anomaly. I thought you might have come across it before and just suggest a quick way to stop it happening.

In this video, is this expected behavior for Final Draft? (It seems to highlight the empty area of the line when clicking on the very right, BTT is currently quit).
https://community.folivora.ai/uploads/default/original/2X/8/8963b0ace828dec588170bd64311e3a9a1d722ff.mov

Not sure. The issue I'm reporting is not when you click at the RHS of the page, by the edge of the page, but when you click just after the full-stop at the RH end of a line of text.

I have just tried to repeat your experience in one of my scripts, clicking at the edge of the page, and only got it to highlight once. I don't really do that in general so can't really say if it is expected behaviour. But what I'm reporting is something different and is definitely NOT expected.

For me this also seems to happen very consistently when clicking right next to the text:
https://community.folivora.ai/uploads/default/original/2X/4/4c0f7e9dfc796b098810e429f47b2c0f70bbc13b.mov (again BTT was quit). This is the issue you encounter, correct?

I'm on the macOS Catalina beta, which might be why it's so consistent here.

It's hard to say because, in the video, you seem to just be floating over the area. In my version, I place the pointer at the end of a line of text, just after the full stop, and click. Then, instead of the insertion point appearing at that spot, (which is does most times), sometimes this highlighting occurs.

I don't think the highlighting floats down to the line below if I move the cursor, however.

Ah I'm also clicking in the video (just moving around the lines and clicking once when I reach the other line).

I'll try to report this to them - I also don't think this is expected behavior and on macOS Catalina it seems to happen pretty much always, even if all other apps are quit.

Is Catalina the beta of the new OS? If so, I don't have it installed yet.

The issue I've reported definitely seemed to stop when I suspended BTT, (not quit), but, because it's an intermittent fault, it's hard to be completely sure about that.

Good luck. As a developer, you may have more luck with them than I did.

Yep it's the beta, and I assume it makes the issue much more visible than before. (I guess that on your macOS version the event handling in BTT could lead to slightly changed event timing, and Final Draft somehow seems to be very dependent on the timing. On Catalina the timing seems to have changed regardless of BTT running or not.

So I think they will definitely want to fix this, otherwise all customers will experience the issue once Catalina is released (today the final Beta will arrive)

OK, so are you happy to talk to them? I can't really report it as I don't have the beta.

yes, I already reported it.

Thank you. Do let me know if there's a response as this bug wastes quite a bit of my time while working.

Very grateful to you for taking time to look at this with me.

Imprint | Privacy Policy