BTT 4.333 is buggy and almost unuseable on Sonoma 14.1.1 and MacBook Pro 16.1

This is the second time i bought BTT after years because i realized that i couldnt update BTT one day.
I did not have a Macbook for a longer time now but kept BTT in mind and decided to buy a lifetime update licence. And i am very surprised about the buggynes of this product by now. It was never so buggy in the past. Sometimes all gestures get messed up and instead of scrolling up or down with two fingers i am navigating back and for websites. Since this version my keyboard all over sudden does not type the letters i am used to but with greek letters (instead of "key" i see κεγ). My shortcuts use option and command buttons and typing these type of letters demand some of those button combos too. Maybe this is useful for you.

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

It sounds like you have some sort of problem with modifier keys (either a hardware keyboard problem or software). If your keyboard is typing greek letters, the system thinks the option key is pressed. This would also explain your gesture issues as they behave differently if such a modifier key is pressed.

Do you have any BTT actions that press a modifier key but do not release it?
It's hard to diagnose what causes the modifier key to get stuck, if possible try to observe when exactly this happens.

Thanks for the support. Since i bought this used macbook some days ago there are just 4 firefox gestures all with modifier keys:

Something with the menu structure is messed up too. Look:

Doesn't sound good - if there are so few triggers in BTT, there is a good chance the issue is caused by something outside of BTT. Let's hope the keyboard on that used Macbook is not broken. Is it one of the Intel based Macbooks? (these had big keyboard issues)

Maybe BTT can help analyze the issue. If you open the advanced trigger conditions of any trigger in BTT, you could see the currently pressed keyboard keys:

Next time your keyboard behaves weird, check whether it does list any key there even if no key is pressed.

Sorry but what makes you think it could be something outside BTT??
Without BTT there are no issues at all with my keyboard. If i have issues i just have to shutdown btt and every thing is fine. This indicates for me that nothing else but BTT causes this bug.
Apart from that i wonder how you come to this conclusion considering that BTT Menue is broken too.
Once again: On the last screenshot you just see a big + Icon and the text above says "choose an action for the chosen trigger". Why can i not see the "command w" text there? This has nothing to do with keyboard or hardware!!! Your argument misses any logic to me so please explain yourself or better: fix it!

besides that i will follow your idea and check the log data.

It has just been the most common thing for the error you described (keyboard typing greek characters, scrolling causing back/forward), I have had very similar reports in the past and it always turned out to be the keyboard (only on Intel machines though, they fixed their keyboards with the Apple Silicon Macs). macOS sometimes has mitigations for keyboard related issues that might not work while BTT is active. Apple even has a service program just to fix the broken Intel MBP keyboards (Serviceprogramm für Tastaturen des MacBook, MacBook Air und MacBook Pro – Apple Support)

However as said this is just one idea. There haven't been similar reports recently so it's most likely not a general issue, which means I need to guess what's happening. The reason why fewer triggers are a sign it's caused by something outside, is because otherwise thousands of BTT users would experience the issue.

The UI issue you see is indeed weird, but the UI is not related to the engine that runs/recognizes the triggers. It could indicate some issue with the internal BTT database though. Did you migrate your BTT setup from another machine or did you set it up completely fresh?

How often do the issues you described in your first post happen? Can you reproduce them somehow?

Oh wait, I just noticed this in your picture:

What are you trying to do there?
This will press the option key, but not release it. This would explain all of your issues. So no broken keyboard :slight_smile: Just delete that action and your issue should be fixed.

1 Like

I believe you are right and found the error. Caused by the user. Sorry for waisting your time and thanks.

1 Like