BST: Previously snapped windows occasionally jump across screen when selected

Describe the bug
Occasionally, a window previously snapped to a custom area will jump to a random position when made active. Often it appears almost entirely off the screen to the bottom left. Sometimes I can see the top right corner of the window on the bottom left of the screen; other times, I have to go to Mission Control to retrieve the window.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
14" Macbook Pro

Screenshots
Unfortunately, the problem happens so sporadically that it's difficult to capture it in a screen recording. I can try again another time though.

Device information:

  • Type of Mac: MacBook Pro (14-inch, 2021)
  • macOS version: Monterrey v12.3 (21E230)
  • BetterTouchTool version: 1.9.5

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Let me know if you have any questions. Thank you for your support!

Hi Danny,

does BetterSnapTool have the screen recording permissions in System Preferences-> Security & Privacy -> Privacy ?

This could help in this case, but I can’t tell for sure.

Yes it does.

Do you have any other mouse/keyboard related app or another window managing app installed?
I haven't heard of a similar issue yet, thus I assume it might be some specific conflict - but it's hard to tell what could cause it.

Yes, actually. I use an electronic writing tablet with my tutoring students.

And now that I'm thinking of it, I believe it happens when I'm screen sharing on Zoom. Both the writing tablet and Zoom have screen recording permissions.

However, the glitch just happened while the tablet was unplugged and no Zoom meeting active, though the tablet driver and zoom were both active processes.

Hey!

Glad you're having this discussion as I'm having a similar issue. I have the same device information as Danny described in his first post.

Any time I try to get a window to snap to a custom area or split screen, the window jumps to a seemingly random location. Changing privacy permissions and restarting BST seem to be ineffective. Rebooting the computer does work, but the issue returns after it goes to sleep or locks.

Thanks for your help in advance!

(PS: I've used BST for almost a decade! It's my number one recommended app!)

this sounds like a different issue, do you maybe have the grammarly app installed? (Latest Chrome stable doesn't work with Better Snap Tool - #29 by Andreas_Hegenberg)

Hmmm. I don't have grammarly installed and this issue is happening with all programs / apps.

it could be a conflict with something else. Are you using the apple on-screen keyboard sometimes? Or any not so common app you can think of?

It appears to have been another app that was causing the conflict. Working great now. Thanks for the help!

do you know which app? then I might be able to fix it

I've tried to determine that. However, I've removed and granted accessibility permissions to all of the apps I have. The issue has not returned.

I will try resetting privileges and get back to you in a week or so. The issue is so sporadic for me that I need to give it some time before declaring it resolved.

Removing and re-granting screen recording permissions seems to have fixed it! Thank you @Braedon_Taylor and @Andreas_Hegenberg!