BST menu bar item not working on Ventura 13.4

Describe the bug:
BST menu bar icon doesn't respond when clicked, and menu shortcut to bring up menu doesn't do anything. And it's orange.

Screenshot 2023-05-25 at 12.07.29 PM

Device information:

  • Type of Mac: M1 MB Air
  • macOS version: Ventura 13.4
  • BetterSnapTool version: 1.9.8

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I'm not really sure when this started, but the BST menu bar icon is orange, and clicking on it, including with any modifier keys, does nothing. Additionally, the shortcut I have set up to pull up the menu does nothing.

All snapping functions and other shortcuts work. It's only the menu bar item that is broken.

have you already tried to restart your system?

Yes, no change.

Very weird. The orange icon usually only shows up on first launch, or if there is a disk file permission error. Such an error can cause BetterSnapTool to not being able to access it's own data file.

Usually a macOS restart fixes file permission issues, but if that's not the case you might need to delete the com.hegenberg.BetterSnapTool.plist file in this folder: ~/Library/Preferences (go there via Finder => Go => Go To Folder, make sure to include the ~). However this would also get rid of custom settings you made.

Just tried that. I quite BST, appended .bak (to back it up) to the plist file, restarted BST, same problem.
Then I repeated the rename of the plist file, restarted my MB, problem persists. Is there a debug mode I can use or log file I can send you to help troubleshoot?

Also, thank you so much for being so responsive, you're an amazing dev!

that is very weird. In that case i would assume something on your system is interfering with BST. Especially because there haven’t been any similar reports. Do you have any menubar manager apps like Bartender installed?

Unfortunately there are no logs for this, most of the menubar item functionality is handled by macOS, which is why it really should do at least something when clicked :-/
Does right clicking do anything?

No, right clicking doesn't do anything. And I am using "Hidden Bar", but I thought about that being the problem, so I've tried BST with Hidden Bar not running (quit BST, quit Hidden Bar, restarted BST), and it's still behaving this way. I'll try uninstalling Hidden Bar altogether, deleting BST plist, then rebooting, and I'll report back if that helps.

Update: I've uninstalled both Hidden Bar and BST, deleted BST plist, rebooted, reinstalled BST from App Store, still doing the same thing. I have no other apps or utilities that should, in any way, affect the menu bar. This is a weird one!