BST is resizing windows, but not snapping to correct coordinates

Describe the bug
For the last few months, my BST has been resizing my windows when dragging into any/all snapping areas (custom and default), but will not PLACE the window in the area that it's supposed to be placed. In other words, the window resizes, but wherever my mouse pointer is when I release the window in the given snapping area is where it will resize the window! See screenshots attached for more info: #1 indicates the correct snapping area in blue, #2 indicates where the window was placed after letting go of the left mouse button.

I have tried reinstalling – this didn't resolve it. Sometimes if I close BST and reopen it will work temporarily, but then it just goes back to the above bug after an unknown amount of time.
Plz help!

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
-Peripheral mouse and touchpad.

Device information:

  • Type of Mac: MacBook Pro (13-inch, M1, 2020)
  • macOS version: 11.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one") Version 1.9.5


Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

i'm having the same issue with my M1 Macbook air, however I noticed the issue only occurs with some applications. Chrome and Firefox suffer from this bug, but Safari works without issue.

I'm running OS 12.0.1 on an M1 Macbook Air. My older 2019 intel MacBook Pro doesn't have this issue on OS 12.0.1, so I think this may be an M1 issue

Chiming in here to report that I'm experiencing similar issues on my MacBook Pro 2019 (16 Inch, Intel i7), on Big Sur 11.16.1, BST app version 1.9.5. So maybe not specific to an M1 chip.

This occurs mainly on Chrome/Edge, but I think I've experienced it on other apps. I am using a wired USB Logitech Mouse (G300s), as well as connected to an HP 27" 1440P display if it matters

Attached a GIF of what I'm seeing
bst_issue_mac

are you running the grammarly app?

Yes I am! Could that be the issue?

I tried quitting the grammarly desktop app and restarting BST but still experiencing the issue

yep, have a look here for a solution: Latest Chrome stable doesn't work with Better Snap Tool - #29 by Andreas_Hegenberg

That definitely improved things. Thanks!

Imprint | Privacy Policy