Blender does not recognize the BTT Shift modifier

Blender does not recognize the BTT Shift modifier.

Under the Trackpad Menu, I have the 4 Finger Swipe Right gesture assigned to the Custom Keyboard Shortcut [Shift A] which should bring up a menu to add an object. Instead, it toggles the Select/Deselect action which is what happens when you enter [A] without the shift modifier. Can this be corrected?

Apple Magic Trackpad and MBP trackpad
macOS 10.13.6
BTT 2.625 (932)
Blender 2.79b (www.blender.org)

I ran into the exact same issue; same system settings except I'm on Mojave.

To make matters weirder, I tried creating a shortcut for animation playback, and the Alt+A shortcut would only work if I ADDED a shift modifier in BTT, to make it Alt+Shift+A, so its almost like shift behaviour has been inverted?

Hopefully there's a way around this, BTT almost salvages the Touch Bar for me!

Just to clarify:

Alt-A was not working in Blender, so you added Alt+Shift+A in BTT. So did you set it up so that Alt+Shift+A sent Alt-A to Blender? And did you specify that was just for Blender?

Imprint | Privacy Policy