BetterTouchTool is not working on official MacOS Mojave

Describe the bug
When trying to open BetterTouchTool in my MBP Late-2012, nothing seems to be opening at all.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MBP Late-2012 Retina.

Device information:

  • Type of Mac: MacBook Pro Late-2012 Retina
  • macOS version: 10.14
  • BetterTouchTool version: 6.4.1

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

when trying to open the application via Show Package Contents -> Contents -> MacOS -> BetterTouchTool, it seems to launch and work in the background, but doesn't really respond to given commands in it.

No crash reports were found so far in my computer for this app.

Have a look at

Hi Andreas,

I've tried it already a few times, but it doesn't seems to open even though..

Did you really delete it from that list in system preferences? (disabling is not enough)

I’ve used app remover in order to clean everything related to this app.
Once I’m applying the activation key, it’s stop working.

Could you check whether there is any crashlog in the macOS Console app under "User Diagnostic Reports" relating to BetterTouchTool?

Your license is fine, I just checked.

from what I've checked - after clean removal of BTT in my computer, and then installing the alpha version mentioned in the first post, BTT does manage to load (even though it shows error finding my trackpad), but as soon as I'm adding the license key or trying to install newer version (even after clean install), it just keep on failing to open the app.

From what I've found in the Console logs, I've seen that BTT is showing the following error:
Unable to load Info.plist exceptions (eGPUOverrides)

also found the following as well:
BUG IN CLIENT OF libsqlite3.dylib: database integrity compromised by API violation: vnode unlinked while in use: /Users/user/Library/Caches/com.hegenberg.BetterTouchTool/Cache.db-wal

I see that this error message is keep on showing as long as the BTT processes are running in the background and keep on crashing every few seconds.

When clicking on User Reports in the Console, it seems to be empty though..

is there anywhere else I should look for it in that case?


I am having the same problem. Bought new license and the restarter does not restart.

iMac Retina 5K Late 2014.

Only crashes are from yesterday, so was the old version and in User Reports.

Most recent dump is here.
Process: BetterTouchTool [1467]
Path: /Applications/
Identifier: BetterTouchTool
Responsible: BetterTouchTool [1467]
5 com.hegenberg.BetterTouchTool 0x000000010fca849e -[BTTTouch userDefaultsChangedForce:] + 2518
13 com.hegenberg.BetterTouchTool 0x000000010fdaa60f -[BTTPluginHandler registerApplicationWithDictionary:] + 1816
14 com.hegenberg.BetterTouchTool 0x000000010fdaa69f -[BTTPluginHandler gotPluginRegistration:] + 46
2 com.hegenberg.BetterTouchTool 0x00000001101d41e8 +[ANSCrashMetadata writeSerializedDictionary:toURL:] + 128
3 com.hegenberg.BetterTouchTool 0x00000001101d51ea -[ANSRotateCrashMetadataOperation main] + 592
4 com.hegenberg.BetterTouchTool 0x00000001101e1d5e -[ANSAnswersController replacePreviousExecutionMetadataWithCurrentMetadata:inRootDirectory:] + 163
5 com.hegenberg.BetterTouchTool 0x00000001101e0cea __56-[ANSAnswersController initWithBetaToken:rootDirectory:]_block_invoke + 453
9 com.hegenberg.BetterTouchTool 0x00000001101b13fb __CLSBinaryImageChanged_block_invoke + 510
1 com.hegenberg.BetterTouchTool 0x00000001101bd9de CLSSDKFileLog + 370
2 com.hegenberg.BetterTouchTool 0x00000001101b501c CLSMachExceptionServer + 201
0x10fc3c000 - 0x110354ff7 +com.hegenberg.BetterTouchTool (2.627 - 936) <338344EC-AC51-3915-A471-221FF8966E9E> /Applications/
0x110edc000 - 0x110f1efff +org.sparkle-project.Sparkle (1.18.1 14071-g6b01db6f4 - 1.18.1) <1522A52C-5418-3863-816B-BED4C543E67E> /Applications/
0x110f4c000 - 0x110f5bff7 +net.wafflesoftware.ShortcutRecorder.framework.Leopard (1.0) <63542887-8F80-387F-A49B-90D3D630F667> /Applications/
0x110f6f000 - 0x111014ff7 +com.mentalfaculty.ensembles (2.6 - 1) <1EFAC5EF-5CE6-3AB2-8ACE-233D7CBF0417> /Applications/
0x11106e000 - 0x111075fff +com.potionfactory.LetsMove (1.21 - 1.21) <300E0114-3781-356C-938F-A9430CEBA497> /Applications/

Hope that helps.

@ebest, these messages are normal, they should not be the issue.
Which alpha version do you mean? In general just install the latest version from (the recovery version on the blog post is only for people with expired licenses)

@JeffBTT this is a weird crashlog, is this the complete one?
Have you downloaded the latest version of BTT?

Also really make sure to delete BTT from System Preferences => Security & Privacy => Privacy => Accessibility (using the minus button) and then add it again.

If downloading the latest version and deleting from Accessibility don't work, please do the following:
1.) Run this terminal command:
zip -r ~/Desktop/ ~/Library/Application\ Support/BetterTouchTool
2.) Send the file which is now on your Desktop to

@Andreas_Hegenberg I’ve tried to install the latest version but it seems to fail when I’m opening it…
Any suggestions how or in which folder should I look for log files of it?

@ebest in general crashlogs are saved in the macOS console app under "User diagnostic reports".
Have you tried the other things I posted? (the accessibility settings and if that doesn't help sending me the zip)


OK, things are working as expected again. It seems there was also an entry in Full Disk Access, that needed to be removed and put back into place. Along with that and removing and replacing in Accessibility and reboot, things are back to normal.

Thank you for your prompt attention!


1 Like

Awesome, glad you got it working!

My download of BetterTouchTool won't even open. Instead, my app Affinity Photo opens, which happens with about half of the software I try to download. Your other app, BetterSnapTool opened just fine. I checked my preferences for security, but BetterTouchTool is not on the list.

Sounds like something is really wrong with your machine, but it doesn't sound like it's related to BTT.

I have really no idea why macOS would open Affinity Photo if you start BetterTouchTool :slight_smile:
Did you double click the downloaded app or did you use some sort of launcher?

Now a new problem. BetterSnapTool downloaded, but doesn't work. Then I tried Snap Areas then Create a New Snap Area and I get a pop up that says: "An Error Occurred. Sorry, BetterSnapTool was unable to get the dimensions of the currently active window. Please make sure the window that you want to use as template is currently active." ---- It was currently active (Chrome).