BetterTouchTool expired too early? Can't using the app anymore. Any solution?

i use the trial mode. still 4 days left, but i can't use it anymore even if i tried other versions. any solution?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
All input devices disabled

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)


Device information:

  • Type of Mac: MacBook Air M2 8/512
  • macOS version: Sonoma 14.2.1
  • BetterTouchTool version: 4.381 (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

A new build will be available in approx. 60 minutes.

1 Like

I just paid for license.. Installed trial recently, spent a lot of time setting up gestures and had exact same issue of BTT expiration this morning. Had to pay for license to get things working again only after few days trials.. Oh well..

I bought BTT Lifetime licence a few months ago and after updating it doesn't work.

Edit: @Andreas_Hegenberg I can't do update

this means your license is not activated on this machine for some reason, try to double-click the license file or click the activation link in the license mail. If that doesn’t work you might need to restart your machine once

I've tried both. For now, I did a downgrade to 4.381

is it possible there are multiple older .bttlicense files in ~/Library/Application Support/BetterTouchTool? (go there via Finder -> Go -> Go to folder, include the ~)

There is only one .bttlicense file

weird, could you send that file to

Sure, I'll

I'm not writing to you because I did something that you wrote here and now it's working but I lost all my presets. Is it any option to restore them?

you can quit btt and rename the folder back, then your presets should be back as well. I‘d recommend to delete the bttlicense file instead of the whole folder

Sadly, it doesn't work - I have clean BTT.
Fortunately, I have a backup from November, so it's not so bad, but it's a bit of a shame that it deleted everything since then

if you just renamed (and didn’t delete) the folder you can definitely get back your presets. If you want you can send the folder to, then I’ll extract your preset)

In case you still get the update error, try downloading the latest build manually:

Was traveling when ALL configurations STOPPED working gave me impression license expired but after checking it is still valid. Not happy working entire day on project without presets working. Installed latest built after reached hotel to fix expiration. Forums have tonnes of posts of app stopped working caused by expiry of license but licenses still valid. Andreas you need to fix this from happening again. Unacceptable that it stopped working suddenly. This thread showing newbies forced to buy licenses too with many more trial days left. Please fix this issue for paid users.

Not a poster on forums, took time to do it because not happy this happened in middle of critical project.

You probably didn't have your license activated on your system. Licensed versions do not expire. Make sure to activate it by double-clicking the license file or clicking the activation link.

Trial versions will expire randomly early 3-4 times per year, that's a anti-piracy feature that has helped me a lot over the years. It's not perfect, but the best system I have.

Thank you very much, but I managed to do it on my own :slight_smile:

1 Like

Bought standard license >1.5 years using on same laptop. All for developers protecting against piracy but you need to protect paid users. Many threads on forum of BTT disabled many times.

1 Like

I don't think there are any threads where a version with installed license expired. Only trial versions expire. I understand that also paid users sometimes use a trial version for a bit until they have imported/activated their license, for this use case I already changed the message a while ago to make clear that you can import your license to fix the issue.

This time there was the faulty 4.384 release which contained a bug that caused the message to pop up if either an older pirated license was installed on the system in the past or the old "free legacy license" was installed on the system in parallel to a valid license. This was a weird edge case that has been fixed in the latest release. (This only applied to users who had manually updated to the 4.384 release yesterday and had either a pirated or free legacy licenses in parallel to their valid license - according to my logs it only affected ~5 users)