BetterTouchTool, DisplayLink, and Ventura Bug?

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.
Using latest version of BetterTouchTool. 3.390

Describe the bug
A clear and concise description of what the bug is.
When I plug in my Plugable hub which connects to my HDMI LG widescreen monitor, the upper menu bar disappears from both my MacBook Pro 16" M1 monitor and the LG widescreen monitor.

I updated to Ventura 13.0 last night and did not connect to my Plugable and monitor until this morning. BTT worked as expected on the MacBook Pro prior to this morning.

I believe the issue is related to BTT because when I turn BTT off, the issue goes away.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro 16" M1, Macally wired keyboard, Plugable Doc (UD_6950PDH), LG HRD Widescreen 35" connected through the Plugable doc using HDMI cable.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)
No screenshots at this time.

Device information:

  • Type of Mac: MacBook Pro M! 16"
  • macOS version: 13.0
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.390

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Sounds like an empty container for the Notch Bar. Could you check whether disabling the Notch Bar feature completely solves your issue?


I should have mentioned that I had unchecked all the Enabled boxes for Notchbar.

Another clue. If I open Display and toggle between two resolutions, it looks like the black menu bar gets repositioned to the middle third of the screen, and the menu is visible again.

In the screen grab below, that black bar is what I am talking about and it goes the entire length of the monitor.

I will reload with the update that just came through and let you know how it goes.

3.931 (October, 25, 2022)

Updated after doing the update.

The issuer continues.

Steps for me to reproduce.

  1. With the machine in clamshell and connected to my external monitor through the doc, open the laptop.
  2. As the monitors do their thing, the menus disappear.
  3. Close the laptop. Only external monitor. The menus still missing.
  4. Open Displays settings and change resolution.

The menu returns, and the black band is now in the upper third of the monitor.

Set resolution to normal. The black band still showing.

  1. Restart BTT. (I’d do this first if I could however, I don’t know how if I can’t see it in the menu. I created my first keyboard trigger to restart BTT. The steps to reproduce are 1-4.)

To fix it, I restart BTT.

I am also experiencing slow snapping on Chrome only. I see this is an issue for others. I keep Chrome updated.

If you’d like me to try an alpha version, just let me know. I’m happy to help.

Sorry my reply was so slow to come. In my haste to get you information, I replied tot he email rather than go back in and reply in the post.

Hope this helps.


weird, maybe the black bar is something else then. Can you go to Help => Export Diagnostic Debug Info in the BTT menubar and send the result to