Bettersnaptool not snapping

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.
I just re restarted .

Describe the bug
A clear and concise description of what the bug is.
Sometimes it functions as it did for years, since a couple of months it no longer does.
Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Imac / touchpad + regular mouse.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Checking for alpha versions

As the first screen shot isn't showing, its 2.427. Though i seem to get the idea from the forum that Better touch tool = better snap tool as well? I was under the impression they're 2 apps from the same dev.