BetterSnapTool half screen not working correctly

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

I have a keyboard shortcut implemented to shift windows to the left/right half of the screen. On all other apps but Google Chrome, all shortcuts work as usual. Recently however the left and right half snaps have not been working correctly— instead, they shift to about the most leftward/rightward thirds of the screen (see picture). Note that all other shortcuts are working on Chrome.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard, Google Chrome

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro, 2018
  • macOS version: Catalina
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    Version 1.9.3

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

usually restarting your system will solve this (happens if the macOs windowing system doesn’t respond correctly to BetterSnapTool‘s commands anymore.

It can also happen if the macOs on-screen keyboard is being used

I have tried all of the following and none have worked: restarting my computer, updating google chrome, and deleting and reinstalling BetterSnapTool. I am also not using an on-screen keyboard.

Any other suggestions?

Did you maybe accidentally change the Google Chrome specific BetterSNapTool settings?


Hello! While I was able to solve my original problem, I seem to be having the same problem again. To reiterate, my problem is that my maximize, left half, and right half snaps are not working correctly, BUT only for Google Chrome! I have been comparing the Specific Settings for Chrome to that of Mail (which works correctly) and they have the same preferences marked but yet still exhibit different behavior.

Here are the settings for Chrome:

And here are the settings for Mail:

Please let me know what could be causing this problem! (Examples of the problem can be seen in the original post.) I have been very annoyed at this app that the same problem has happened multiple times now!