Better Touch Tool will no longer run in background since update license expired

I do not know if this is a bug or deliberate behavior, but I purchased Better Touch Tool two years ago with a license to get free updates for two years and keep indefinitely. To be honest I didn't care about the updates, as I do not want the ever increasing layers of complexity that seem to come with each one. I just wanted a tool that would work the way it worked when I bought it unless broken by a major OS release--at which point I would be happy to purchase a new version.

Anyway, all was well until my "update license" expired. I received an on-screen message prompting me to purchase a new update license or else keep using without the updates. I chose the latter. In response, I found that BTT had actually been disabled, and the icon was grayed out (why is this a response to my update license ending?). I re-enabled it. After that I found that unlike previous behavior where I was able to close BTT with command + Q and it would keep running in the background (with an icon in the menu bar), it will no longer keep running in the background when closed with command + Q. I have to keep the program open in the dock or it isn't running. I really don't want to have it open in the dock all the time, and would like the behavior to return to how it was.

So I am wondering, why was the behavior of the application changed when my update license ran out, and how do I fix this? Am I missing a setting that was spontaneously changed when the license ended?


System: MacBook Pro
macOS 10.14.6 (18G3020)
kernel version: Darwin 18.7.0
BTT version: 3.335

Not sure, but this works for me. Use cmd-W to close the BTT window. cmd-Q quits the entire application. With these settings the BTT icon is not in the Dock, but stays in the menubar.

Thank you, that does work! However I would still like to know why the behavior changed when the updates expired, because that is definitely not the way it was before.

It's a BTT bug, will be fixed with the next release.

For now the best fix is to enable "silent updates" in the BTT preferences.

Sorry, to clarify, was the bug introduced in the most recent version of BTT, or was it triggered by my updates expiring? I would like to know because I won't get any more updates (I'm not sure whether bugfixes with "silent updates" counts or not), so if it was just introduced, I can try to roll back.


Hello Andreas. I have not received a response to my last post, and Better Touch Tool is still not working properly. Now my window button triggers are not working anymore, and BTT is reopening itself in the dock after resuming from suspend (instead of staying open only in the menu bar). On my other machine the behavior is the same. It is also disabling itself and not providing a clear option to re-enable it (it has an option to re-enable for the active app, but not for all apps . . . toggling this twice seems to have re-enabled it for all apps, but I'm not sure, since some functionality is still missing, and why is it disabling itself in the first place?). It has repeatedly prompted me to buy an extension to my update license, and that is not at all something I am planning to do given this behavior.

Better Touch Tool worked fine through the two year update period, but it seems as soon as paid updates expire you remove the functionality from your product. This is absolutely contrary to what was promised. As a customer who paid for this product in good faith, I am very upset to be dealing with this issue right now. I would appreciate a response.

Edit: My "zoom window under cursor" window trigger had disappeared. I re-added it and it works again. I have not touched this functionality in two years. Why are things like this being removed spontaneously? And I still have the issue of BTT disabling itself and continually reopening in the dock after suspend.

there is definitely no feature removed if you stay on your old version. It sounds like you might have accidentally disabled BTT and removed something accidentally. BTT does really nothing when your license expires.

For the dock issue please try the silent update fix I posted above, this is also not related to your license but it was a bug in some older versions. (which luckily can be fixed easily as described above). It‘s a bug related to showing the update window, which was probably introduced when I added the silent update functionality - I think that was sometime before Christmas. It has been fixed in current BTT versions.

If you want you can send me the debug information (Help -> Export Debug Information) then I should be able to tell which interactions caused the disabled state & the removal of the zoom window trigger)