Better Touch Tool sticks on left click button in Lotus Notes

Describe the bug

There is an issue with better touch tool, where in Lotus Notes (email client) when I navigate and left click with Magic Mouse the button seems to occasionally stuck and the email or folder selected becomes as sticked to the mouse pointer and starts moving with the mouse. This causes folders to be moved or mails, and sometimes if I do not pay attention and I am in a hurry, I miss-place folders or mails and it is hard to find them later on.
This is happening for at least the last 5 versions of bettertouch tool and I suppose is related with Java or Eclipse environment of Lotus Notes. I tried different setting on the mouse, however the issue still persist.

**Affected input device Magic Mouse (haven't checked with other input devices).

The problem is self explanatory, if needed I will try to capture screen shots, however it is easily recreatable as it is happening almost all the time.

Device information:

  • Type of Mac: MacBook Pro 2015
  • macOS version: Mojave, however this was happening on the previous two versions as well.
  • BetterTouchTool version: The latest one 2.660

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Unfortunately some (especially Java) apps don't support the macOS default APIs correctly, which can cause such things.

If you don't need BTT for Lotus, the easiest solution would be to disable it for Lotus Notes (click the BTT menubar icon, select "Disable For..."